1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Java-Applets notwendig?

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von Aybee, 04. Juli 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Aybee

    Aybee Benutzer

    Wie ich feststellen musste, benutzen 90% der Leute Winamp. Normalerweise sollte in der heutigen Zeit eigentlich jeder Java haben *g*.

    Aber wir werden auf der neuen Page (siehe hier) mal vermerken, daß Java erforderlich ist.

    Was meint Ihr dazu?

    LG
     
  2. ForenKater

    ForenKater Benutzer

    AW: Java-Applets notwendig?

    Mich persönlich stören JAVA Anwendungen in Websites immer. Die Ladezeit verlängert sich durch das Laden des Frameworks und Contents doch sehr beträchtlich, absturzanfällig ist es (bei mir) dann auch noch..
     
  3. Aybee

    Aybee Benutzer

    AW: Java-Applets notwendig?

    Nunja sehe es so, ohne Java geht vieles nicht, wie z.b IRC Chat über die Page, das ist das beste bespiel dafür das man es braucht. Und wie ich schon sagte ich habe keine Prob mit java,viele andere auch nich,t wie wir erfragen konnten, und getestet habe, ob auch alles geht.
     
  4. MichaNRW

    MichaNRW Benutzer

    AW: Java-Applets notwendig?

    Das stimmt so aber nicht. Ein IRC-Chat ist auch mittels PHP realisierbar. :p
     
  5. ForenKater

    ForenKater Benutzer

    AW: Java-Applets notwendig?

    Wozu gibt es CGI-IRC? :) JAVA Applets finde ich gehören maximal dann in die Homepage, wenn es um wirklich nicht anderweitig realisierbare Dinge geht; Als Beispiel: Spiele (Wobei sich hier auch eher Flash anbietet) oder Bildbearbeitung Online usw.

    Davon ab: Woher weißt Du das Du nicht viel mehr User hättest OHNE Java? :cool:
     
  6. Aybee

    Aybee Benutzer

    AW: Java-Applets notwendig?

    Warum sollten mehr User kommen!? Es sind soweit ich weiß nur für 1 sache java von nöten und zwar für den IRC Chat.Um den Stream zu hören,brauch man kein java sondern winamp,media-player,real-player das war es auch schon!

    Aber das hat sich vorerst erledigt wir hatten gestern Nacht einen Hackerangriff auf unsere Page :( Und jetzt hoffen wir das wir ein backup noch haben.
     
  7. Pegasus

    Pegasus Benutzer

    AW: Java-Applets notwendig?

    Entweder habt ihr dann die Plugins falsch eingebunden oder du bist auf dem Holzweg. Ich hab Realplayer und den WMP 10 installiert, kann aber mit beiden ebi euch nicht hören. Java darf bei mir nur auf Seiten "aktiv" werden, bei denen ich das explizit erlaube. Und auf Seiten, die mir nicht sagen, wofür Java nötig ist, erlaube ich das nicht ;)

    Und wenn 90% Winamp nutzen, heisst das, das evtl. 10% der evtl. Hörer verloren sind. Wenn euch das reicht, ist das ok, ich persönlich bin der Ansicht, das es das Ziel sein soll, 100% der möglichen Zielgruppe zu erreichen.
     
  8. Aybee

    Aybee Benutzer

    AW: Java-Applets notwendig?

    Dann sag mir, wie es richtig geht. Bitte das alle ohne java hören können. Naja also wie gesagt ich brauch bis jetzt keine java um zu hören! Ich brauch nur für den IRC Chat java falls man ihn nutzen will!
     
  9. Pegasus

    Pegasus Benutzer

    AW: Java-Applets notwendig?

    Rein aus Prinzip widerspreche ich jetzt mal :p

    Das einzige, was du per PHP machen kannst, ist ein Frontend per PHP (Java und CGI sind aber auch nur Frontends ;))
    Der eigentliche IRC-Server kann nur in C Programmiert werden, weil Zugriff auf Ressourcen nötig ist, die von jeglichen Webtechnologien aus Sicherheitsgründen nicht erreichbar sind.

    Und ein Applet ist immer noch am Ressourcenschonensten für den Server, da das Applet im Browser ausgeführt wird und CGI und PHP auf dem Server, was wesentlich mehr Traffic und ein vielfaches an Prozessor-/Speicherlast erzeugt.

    Ich denke, solche Dinge sollte ein Webmaster mit einkalkulieren, um seinen Besuchern den "optimalen" Webauftritt zu präsentieren.
     
  10. ForenKater

    ForenKater Benutzer

    AW: Java-Applets notwendig?

    Ähem, ein kompletter PHP Chat verbraucht mit so ein paar Userleins nicht so viel Last das ein Server in die knie geht *hust*räusper* Ab 20 aufwärts wirds da aber schon enger *g* Wenn Du allerdings ein PHP/CGI Frontend benutzt für einen IRC Chat hält sich das mit der Serverlast noch in Grenzen da der "Server" nicht über PHP/SQL/etc. abgehandelt wird
     
  11. Pegasus

    Pegasus Benutzer

    AW: Java-Applets notwendig?

    Also, ich habs grad nochmal angeschaut.
    Java ist wirklich zum hören nicht nötig. Mein Firefox 1.0.4 hat zwar die Plugins für Real und Media Player installiert, startet diese aber nicht in euren Popups.

    Ich kann noch nicht sagen, woran es liegt, seh es mir aber an. Ich vermute mal, das es Probleme macht, das du keine .asx-Datei angibst (Media Player) aber wie gesagt, muss ich mir ansehen.
    Sobald ich zu nem Ergebniss gekommen bin, werd ichs hier posten :)

    Und als Alternative zum Applet würde ich einen Freeware IRC-Client zum Download anbieten, dessen Link erscheint, wenn kein Java aktiviert ist. Dazu im <applet>-Tag einfach ein alt="Hier können sie alternativ zum Java-Chat einen kostenlosen Clienten für unseren Chat downloaden: <link>" oder so ähnlich.
     
  12. Aybee

    Aybee Benutzer

    AW: Java-Applets notwendig?

    Hehe Mit dem Java Chat ist eine gute werde ich auch umsetzten... Aber wie gesgat warum einige hier Probleme haben das sie Java brauchen verstehe ich nicht..
     
  13. ForenKater

    ForenKater Benutzer

    AW: Java-Applets notwendig?

    Vielleicht weil gerade erst eine kritische Sicherheitslücke in der MS Javamaschine aufgetaucht ist und man einfach ein wenig vorsichtiger ist was man auf fremden Webseiten ausführen lassen möchte- und was nicht.
     
  14. Pegasus

    Pegasus Benutzer

    AW: Java-Applets notwendig?

    Wenn dir ein paarmal Trojaner und Viren über die JVM in den Rechner gepflanzt wurden, verstehst du es vielleicht. Die JVM von Sun ist auch nicht perfekt, wenn auch um Welten besser als die von MS.

    Aber wieder zum Thema. Das im FF die Plugins nicht staretn, liegt an der fehlenden ActiveX Unterstützung, die in Gecko erst experimental ist.

    Ich werd für WMP und Realplayer eine Beispielseite schreiben und für die FAQ bereitstellen. Müsste ich übers WE schaffen. Ich teste vorher mit IE und FF, dann sollte es im Opera und Konqueror auch funktionieren :D (Teste ich, sobald ich mal wieder ein Linux auf meiner Workstation hab)
     
  15. ForenKater

    ForenKater Benutzer

    AW: Java-Applets notwendig?

    Hm, man kann durchaus WMP und RP in FF anzeigen lassen - EMBED und OBJECT machens möglich..
     
  16. Pegasus

    Pegasus Benutzer

    AW: Java-Applets notwendig?

    Dafür brauchst du aber die entsprchenden Dateien auf dem Server (.asx und .rm)
    Und dafür schreib ich Beipsielseiten, die dann bei bedarf als .zip zur Verfügung stehen.

    Nur hab ich heute keine Lust mehr und morgen keine Zeit. Der Code ist schon fertig, aber noch nicht kommentiert und bereinigt. Deshalb erst am WE

    PS: OBJECT kannste beim FF vergessen, da geht nur EMBED. OBJECT ist für ActiveX und wenn du Java etc. als Objekt einbinden willst. Ich hab vorgestern dev.mozilla.org durchforstet und Festgestellt, das OBJECT im FF immer noch experimental ist
     
  17. ForenKater

    ForenKater Benutzer

    AW: Java-Applets notwendig?

    Ja, ich meinte ja, OBJECT UND EMBED benutzen. Macht man eigentlich parallel so, damit es kompatibel ist.

    Klar, ASX und RM muss vorhanden sein.
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen