1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Linux-Server: Windows Media-Player bekommt keine Verbindung

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von Hiddi, 22. September 2009.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Hiddi

    Hiddi Benutzer

    Betreff: Linux Server (Problem bei, Windows Media Player bekommt keine Verbindung zum radio Stream..)
    Hallo Liebes radioforen Team,

    Ich hoffe ich bin hier richtig, bin schon sehr lange auf der suche nach einer lösung zu mein Problem..
    Und zwar ich bin gerade dabei ein Webradio auf zu machen. Und habe auf Linux schon ein stream installiert
    mit Playlist die mittlerweile auch schon läuft.

    Das Problem an der ganzen sache ist ich habe mir Stream Player gebaut
    ( Winamp Player, Windows Media Player, Real Player).
    Davon gehen Winamp Player und der Real Player, und das Problem an der sache ist der Windows Media Player
    bekommt keine Verbindung zum stream...

    Ich habe das ganze jetzt auch schon Manuell versucht... also sprich Windows Media Player auf dem Pc geöffnet
    und dann oben unter >> Datei>> URL öffnen die stream Ip eingeben, nur das auch ohne erfolg.
    Der Stream will einfach nicht anspringen bei dem Windows Media Player aber alle andren wie Z.b
    Real Player, Winamp Player das fuktioniert es einfandfrei.

    Ich habe mir mal so meine gedanken darüber gemach, einzigste möglichkeit nach meinem erarnen
    liegt es an meinem Linux Server den ich bei Webtropia gemietet habe.
    Ich denke mal das ich irgend wo auf dem Linux Server einstellen müsste, das der Windows Media eine Verbindung
    zum Stream aufbauen darf? Oder nicht? so denke ich im moment..

    Ich habe jetzt auch schon mittlerweile mein Hoster angeschrieben und habe ihn mein Problem erklärt.
    Er schrieb darauf hier !!!

    Hoster:
    Von: Support
    Am: 16.09.2009
    Um: 17:43:41 Hallo,

    wir können nur supporten, was wir auch in unserer Standardinstallation anbieten.
    Ich kann Ihnen versichern, dass von unserer Seite keinerlei Einschränkungen bezüglich auf den vermieteten
    Servern laufender Dienste gibt.

    Vielleicht finden Sie ja in den Logfiles Ihres Servers oder des Mediaplayers Hinweise auf den Grund der
    nicht zustanden kommenden Verbindung.

    Viele Grüsse aus Düsseldorf

    Christian Gramsch
    Von: Support
    Am: 16.09.2009
    Um: 17:47:31 Hallo Herr Hiddessen,

    der Stream läuft und die Tatsache, dass nur der WMP nicht verbinden kann, deutet darauf hin,
    dass der Stream nicht Konform mit dem WMP ist; somit müssten Sie den Hersteller des
    Streaming Servers oder Microsoft kontaktieren.

    In den meisten Fällen finden Sie in den Foren der Hersteller Hinweise auf oft auftretende Problem.

    Bitte beachten sie auch, dass Sie Admin des Servers sind und diesen administrieren müssen.

    Mit freundlichen Grüßen aus Düsseldorf

    Mark Kangun
    ...
    Ich: Also ich check da echt nicht mehr durch... ich habe sogar über diamant-hosting.de/streambox/
    eine Stream Box Manuell erstellt.. da klappt es auch nicht !! was wieder funktioniert hat war der
    Winamp und Real Player aber wie gesagt der windows Media Player will einfach nicht...
    Es haben jetzt auch schon mehrer Freunde von mir versucht Manuell den Stream über
    Windows Media Player zu starten.. nur auch da klappt es nicht !!

    Ich bitte um dringende Hilfe

    Die Stream Url ist 85.114.135.160:8000 ihr könnt es ja selber mal ausprobieren über den
    Windows Media Player >>> Datei >> URL ÖFFNEN.. und ihr werdet sehen das es nicht klapt.
    Und das ist mein problem was mich tierisch aufregt.
    Es muss irgend wie an meinem Linux Server liegen anders kann ich es mir garnicht mehr vorstellen...
    Ich habe ein Linux Server Debian Etch 4.0 32bit mit SoftwareRaid mit Plesk


    Habe gerade auch eine Stream Box erstellt hier mal ein Test!!!
    http://humfelder.de/stream/test.htm
    Der Winamp geht wieder ... nur der Windows Media Player wie immer Nicht!!!

    Die Datei liegt hier http://www.humfelder.de/stream/HumfelderMedia.wax

    http://humfelder.de/stream/lol.asx

    Bei diesem Link http://www.humfelder.de/stream/HumfelderMedia.wax öffnet sich ja der
    Windows Media Player und versucht zu verbinden !!! aber dann zeigt er Fehler meldung an

    http://85.114.135.160:8000/ <<<mir wurde gerade gesagt das die
    Playlist (sc_trans) Content Type: audio/aacp sendet... und deswegen spielt der Media Player das nicht ab..
    Ich habe aber gesehen das bei andren Online radios das die Playlist über audio/mpeg sendet
    und soo möchte ich das auch haben weil so springt auch der Windows Media Player an !!

    ich bitte um Hilfe .....
     

    Anhänge:

  2. Sven76LDK

    Sven76LDK Benutzer

    AW: Linux-Server: Windows Media-Player bekommt keine Verbindung

    Hier mal eine Frage in die Runde:
    Kann der Windows-Media-Player ohne zusätzliches Plug-In überhaupt AAC+ ?
    Soweit ich weiß nicht...

    @ Hiddi:
    Ich würde Deinen Server mal als Fehlerquelle ausschließen!
    Für mich liegt das Problem am Übertragungsformat AAC+ ("Content Type: audio/aacp").
    Stelle doch einfach Deinen Stream auf mp3 (Bitrate mind.128kbps!) um.
    Das kann jeder Player und so viel mehr upstream brauchste dafür auch net.
    Dann kommt auf der Shoutcast-Page auch: "Content Type: audio/mpeg"...
    ;)

    LG
    Sven
     
  3. Hiddi

    Hiddi Benutzer

    AW: Linux-Server: Windows Media-Player bekommt keine Verbindung

    So hier habe mal meine sc_trans.conf rein gestellt, ich habe jetzt im sc_trans umgestellt das die Playlist mit 128 kbps sendet.. So und es hat nix geholfen die Playlist sendet weiterhin immer noch mit audio/aacp so ein Dreck ich möchte das die Playlist mit mpeg sendet das kann doch alles nicht so schwer sein..:mad:.

    ; Sample sc_trans/0.35-j config file
    ; j.frankel 12/05/00
    ; t.pepper 10/31/00
    ; (relays not supported, yo)
    ;
    ; sc_trans operates in one of two modes, either reading mp3s off disk, decoding,
    ; re-encoding, and then broadcasting them, or relaying from a shoutcast server,
    ; transcoding to a lower bitrate, and broadcasting to a new server.

    ; sc_trans accepts the following signals:
    ; HUP - flush logfiles (close and reopen) -- will make console logging stop
    ; WINCH - jump to next song
    ; USR1 - reload playlist off disk (will not interrupt current playing stream)
    ; USR2 - toggle shuffle on/off
    ; TERM - normal sc_trans shutdown (clean)

    ; PlaylistFile (required EVEN IF RELAYING) - playlist file (to create, use
    ; find /path/to/mp3/directory -type f -name "*.mp3" > playlist_filename.lst
    PlaylistFile=lieder.lst

    ; ServerIP/ServerPort are the target server to send to
    ServerIP=127.0.0.1
    ServerPort=8000

    ; Password is the password on the sc_serv you're sending to.
    Password=*****

    ; StreamTitle/URL/Genre define the data that appears on the directory and in the
    ; stream info.
    StreamTitle=Humfelder Radio
    StreamURL=www.humfelder.de
    Genre=

    ; Logfile optionally denotes a text file to log sc_trans to. a kill -HUP
    ; will force a close and re-open of this file (but will also cease logging to
    ; the console)
    LogFile=sc_trans.log

    ; Shuffle the playlist
    Shuffle=1

    ; Bitrate/SampleRate/Channels recommended values:
    ; 8kbps 8000/11025/1
    ; 16kbps 16000/11025/1
    ; 24kbps 24000/22050/1
    ; 32kbps 32000/22050/1
    ; 64kbps mono 64000/44100/1
    ; 64kbps stereo 64000/22050/2
    ; 96kbps stereo 96000/44100/2
    ; 128kbps stere0 128000/44100/2
    Bitrate=128000
    SampleRate=44100
    Channels=2
    ; Quality is from 1-10. 1 is best, 10 is fastest.
    Quality=3


    ; Mode=0 for none, 1 for 100/100->100/0, 2 for 0/100->100/0
    CrossfadeMode=1
    ; Length is ms.
    CrossfadeLength=8000

    UseID3=0

    ; Public determines whether or not this station will show up in the directory
    Public=1

    ; Put stuff here for user interaction (AOL IM, ICQ, IRC)
    AIM=
    ICQ=
    IRC=
     

    Anhänge:

  4. Inselkobi

    Inselkobi Benutzer

    AW: Linux-Server: Windows Media-Player bekommt keine Verbindung

    Richtig!
    Kanner nicht.

    Mir stellt sich die Frage allerdings noch, wozu man bei 128/44 noch AAC+ verwenden muss.

    Na, jedem das seine.
     
  5. McCavity

    McCavity Benutzer

    AW: Linux-Server: Windows Media-Player bekommt keine Verbindung

    Zum Abspielen von AAC+ auf Windows Media Player: Orban Plugin (auf der Seite nach ganz unten scrollen)

    Verwendest Du sc_trans 2.0? Falls ja, dann hat der ein paar neue Features (da sollte eine demo sc_trans.conf dabei sein), einer davon wäre:

    Code:
    encoder=mp3
    Vielleicht hilft das was?

    LG

    McCavity
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen