1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Probleme mit der Samplerate

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von Archetim, 22. November 2008.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Archetim

    Archetim Benutzer

    Hallo,

    folgendes Problem habe ich, bei dem ich auf Eure Fachkenntnis und/oder Erfahrung hoffe ...

    Ich sende für ein kleines, lokales Webradio. Die Software ist der SAM 4, läuft auf einem Windows XP Pro mit SP2 und allen aktuellen Updates. Die Hardware ist ein älterer 1800 Mhz AMD Sempron mit 1 GB RAM.
    Im SAM habe ich den MP3 Pro Encoder laufen, eingestellt auf 96 kbit mit 44 khz Samplerate. Bei den Einstellungen hat mir der Inhaber des Radios geholfen, der mit der gleichen Software sendet.

    Das eigentliche Problem dabei: Ich sende laut SAM mit einer Samplerate von 44 KHz, die Hörer empfangen aber nur 22 KHz (kriegen das ja im Winamp angezeigt). Beim Inhaber, der übrigens im gleichen Ort beim gleichen Provider sitzt, werden 44 KHz empfangen. Wir senden beide über eine T-DSL 1500er Leitung. Bei einem weiteren DJ, der mit einer älteren Version des SAM mit 44 KHz aus einem anderen Ort sendet, empfangen wir 32 KHz.

    Da ich persönlich keine wirklich guten Lautsprecher am PC habe merke ich keine Unterschiede, wüßte aber doch gerne, wie sowas sein kann und welche Auswirkungen das praktisch hat?!

    Grüße aus Bayern,
    Archetim :cool:
     
  2. Studio Rebstock

    Studio Rebstock Benutzer

    AW: Probleme mit der Samplerate

    Das hat Stil. Respekt! :cool:
    Fragen am Rande: Was empfängst DU denn, wenn du dich zu deinem eigenen Hörer machst? Empfangen alle vom gleichen Server oder ist da irgendwo im Relay was schief gelaufen (wenn das denn überhaupt möglich ist)?

    Lässt sich das Problem auch auf dem Teststream reproduzieren?

    Erheiterte Grüße (sorry), Uli
     
  3. Archetim

    Archetim Benutzer

    AW: Probleme mit der Samplerate

    Hallo Uli,

    die "erheiterten" Grüße kann ich gut nachvollziehen. Da ist auch keine Entschuldigung nötig :D
    Ich habe auf dem Teststream ein bisschen experimentiert und bin zu folgendem Ergebnis gekommen.

    Im MP3Pro-Encoder kann ich neben dem Format (96 kb/s, 44,1 kHz) auch noch die Qualität (Fast, Medium, High Quality) einstellen. Egal, was ich bei der Qualität mache, es kommen am Ende 22 kHz beim User (ich selbst) an.

    Zum Vergleich habe ich den Standard-MP3-Encoder eingerichtet, der ebenfalls zum Lieferumfang des SAM gehört. Das Format ist das Gleiche, die Qualität lässt sich unterscheiden in Fast Resampling und High Quality. Beim Fast Resampling kommen tatsächlich 44,1 kHz an. Stelle ich die Qualität auf High Quality bekomme ich im SAM eine Meldung, nach der IMMER die optimale Samplerate für die gewählte Bitrate gesendet wird, egal welche Einstellung ich vorgenommen habe. Dabei kommen 32 kHz an, was offensichtlich dem Optimum für eine Bitrate von 96 kb/s entspricht.

    Diese Ergebnisse lassen sich 1:1 vom Test- auf den Hauptstream übertragen, so dass das Problem gelöst scheint. Verstehen tu ich's trotzdem nicht :wall:

    Gruß Archetim :cool:
     
  4. Cyric

    Cyric Benutzer

    AW: Probleme mit der Samplerate

    wenn ich mich da recht erinnere muss auf der gegenseite auch ein mp3Pro Decoder installiert sein damit MP3Pro als MP3Pro und nicht als Standart-MP3 wiedergegeben wird. Da der MP3 Pro Codec des Frequenzspektrum aufteilt und beide Teile seperat komprimiert, muss an anderen Ende beides wiederzusammenkommen. Der StandartMP3 Codec erkennt aber nur den 'unteren' Frequenzbereich und ignoriert den Rest, was auch neben den Akkustischen Folgen (Höhenverlust) zu dem Anzeigefehler führen kann. Ist nur ein Gedankenansatz, MP3Pro Codec (neu) installieren.
     
  5. melamad

    melamad Benutzer

    AW: Probleme mit der Samplerate

    Einige Player kommen mit MP3-Pro nicht klar, für die alten Winamp-Versionen gab es ein Plugin dazu.

    Daraus resultiert dann die Anzeige der verringerten Sampling-Rate, weil platt gesagt bei MP3Pro, die als Mp3 ausgelesen werden die Hälfte fehlt.
    Es müsste auch Sch... klingen, da die Höhen fehlen.

    Google hilft da aber gerne weiter...
     
  6. Archetim

    Archetim Benutzer

    AW: Probleme mit der Samplerate

    Hallo Cyric,

    danke für die Erklärung und den Denkansatz. Jetzt ist mir zumindest klar, warum es so ist, wie es ist.
    Habe den MP3Pro-Codec für den Winamp mal installiert und siehe da ... es funktioniert. Ich empfange tatsächlich 44,1 kHz.

    Vielen Dank :cool:
     
  7. Studio Rebstock

    Studio Rebstock Benutzer

    AW: Probleme mit der Samplerate

    Nur zur Befriedigung meiner Neugierde:

    Wiki kotzt sich dazu wie folgt aus -
    Jetzt die große Preisfrage - wenn ich im upstream nicht limitiert bin und es keine Verbindungsunterbrachungen im 128er Stream gab, warum sollte ich dann heute noch mit mp3pro streamen?

    Ist nicht als Vorwurf gedacht, sondern nur eine Frage, die mich nicht ruhen lässt.

    Gruß, Uli
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen