1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

SAM4: Stream bricht ab

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von classicsFM, 10. September 2007.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. classicsFM

    classicsFM Benutzer

    Hallo,

    ich habe ein Problem mit Sam4. In unregelmäßigen abständen reist die Verbindung zum Hörer ohne erkennbaren Grund ab. Das System ist zur Zeit folgender Maßen aufgebaut:

    Win2003 Server mit Firebird Datenbank und Sam4

    auf dem Server laufen 4 Shoutcast Server, welche mit unterschiedlichen Bitrates beliefert werden.

    Während der Stream beim Hörer einfach aufhört zu laufen, gibt es weder in den Logfiles von sam noch von Shoutcast Einträge, die darauf hinweißen könnten. Die Encoder laufen ohne unterbrechung weiter.

    Hat jemand eine Idee woran das liegen könnte? Danke & Grüße
     
  2. Pegasus

    Pegasus Benutzer

    AW: sam4 - Stream bricht ab

    Ich würde sagen es liegt an der Bandbreite der Netzwerkverbindung. Die ist zu gering für die Hörer.
     
  3. classicsFM

    classicsFM Benutzer

    AW: SAM4 - Stream bricht ab

    Also an der Bandbreite kann es nicht liegen.

    Der Server ist mit 100 Mbit angebunden (Hosteurope Rechenzentrum)

    Nachtrag: Der Stream bricht bei allen gleichzeitig ab
     
  4. T. Paul

    T. Paul Benutzer

    AW: SAM4 - Stream bricht ab

    Taucht in SAM eine Fehlermeldung im Event Log auf? Irgendwas wie "Unable to send data fast enough".
     
  5. classicsFM

    classicsFM Benutzer

    AW: SAM4 - Stream bricht ab

    Die Logfiles sind leer.
     
  6. Mr.BSE

    Mr.BSE Benutzer

    AW: SAM4: Stream bricht ab

    nabend,

    weiß nich tob es wirklich weiter hilft, nur ein gedankengang von mir.
    Da die encoders scheinbar weiter aktiv sind, denke ich nicht das das Probs beim der verbindung sam->Shoutcast zu suchen ist, eher Shoutcast->Hörer
    ggf. Houtcast-Transcoder->Hörer
    der Shoutcast ligt gewöhnlich auf dem Server, sonst wärs ja quatsch...
    Eine frage, im errorlog des Server, kann ggf. was von MAXuser stehen hatte das Problem vor ca. 2 jahren, das irgendwie die Maximale zugriffszahl an usern auf eine bestimmte Menge Begrenzt war.

    Laß dich nicht mit den 100MB anbindung täuschen, in den meisten fällen Hängt zwar der server an einer 100MB anbindung aber auch weitere Server so dass die 100MB sich mit den anderen Servern geteilt werden muß.

    Tritt das Problem jedesmal zur gleichen ZEIT auf?
    Cronjobs mal schecken vielleicht ist da was bei was die Ports dort kurzzeitig dicht macht...
    oder mal die SC_CONF checken irgendwo steht da was eine zahl, 8192 oder so... sollte meist nicht geändert werden, manchmal steht dort auch eine in der größenordnung zweiundreißigtausend und irgendwas....

    die Netzwerkverteilung der Shoutcast ggf. mal checken.. da steht was von CPU nutzung und so... müßte mir das ganze mal raus kramen, hab ich leider grad net zu hand....

    wenn die hörer aber alle, sagen wir mal 5 min fliegen, da gibt es eine einstellung in der SC_Conf wo man bestimmen kann das jeder Hörer nur xxx secunden (300sec=5min) draufbleiben dann automatisch gekickt werden.

    vielleicht ist auch ne gewisse vorzugs IP liste aktiv....

    dieser 8000 und nochwas wert ist wichtig... auch ein wert wieviel der SC zwichenbuffert kann ne ursache sein. möglicherweise ist zwar die Datenanbindung des Server ausreichend, aber vielleicht die Serverleistung selbst nicht.

    wie gesagt, alles nur vermutungen und sollen eher zur Fehleranalyse denkanstöße geben... hoffe das ihr den Fehler schnell findet.

    Achtet mal drauf beim nächsten mal, wieviele Listener drauf waren.
    Achtet auf die Uhrzeiten wann es vorkommt.
    Ist es regelmäßig oder nur einmalig Pro tag? oder ist es eher unregelmäßig.
    Passiert es auch wenn ihr mal einen Stream weglasst? also statt mit 4 nur 2 oder 3 Shoutcast's
    verwenden alle 4 Shoutcast hoffentlich eigene Logdateien
    ggf. in der sc_conf die logdateinamen anpassen.


    mehr fällt mir erstmal nicht wirklich ein...

    ob es hilft weiß ich zwar nicht, aber ich hoffe das es weiter bringt.

    Lg Mr.BSE
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen