1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Streaming mit On-Board-Sound?

Dieses Thema im Forum "Internetradio- und Heimstudio-Hardware" wurde erstellt von SkyCircle, 30. Oktober 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. SkyCircle

    SkyCircle Benutzer

    Hallo alle Miteinander,
    habe mich neu angemeldet und gleich eine typische Newbie-Frage,
    habe in der Suchfunktion nichts gefunden, sorry also dafür!

    Momentan plane ich an einem eigenen Radiokonzept,
    habe bereits früher (noch mit ISDN und 450-MHZ-CPU) einige Sendungen ausgestrahlt und bin dann einfach aus Zeitgründen davon abgekommen. Nun habe ich einen aktuellen (ALDI)-PC mit Intel-Soundchip, habe Shoutcast installiert und zum ausprobieren die Teststream-Server der jeweiligen Provider benutzt. In der Audiosteuerung habe ich den "Stereo Mix" ausgewählt, um sowohl Sprache als auch Musik via Winamp steuern zu können.

    Bei der Wiedergabe von einem anderen System klingt die Wiedergabe jedoch im ersten Augenblick so, als würde sie viel zu langsam abgespielt werden, beim genaueren Hinhören merkt man dann, das die oberen Frequenztöne der Titel abgeschnitten sind, es also alles sehr dumpf und "spacig" klingt.

    Beim Test mit meinem alten 450MHZ-System, der noch mit einer ISA-Soundkarte ausgestattet ist, traten diese Probleme nicht auf, die gleichen Titel und auch meine Stimme wurden perfekt wiedergegeben.

    Daher nun meine Frage: Kann dieser Fehler, der ja vermutlich beim Encoding geschieht (Die eigentlliche Soundwiedergabe via Line-Out funktioniert wunderbar!!) vom Soundchip stammen? Würde der Kauf einer PCI-Soundkarte diese Probleme lösen? Wenn ja, welche (natürlich möglichst günstige) wäre empfehlenswert?



    Vielen Dank für eure Hilfe und schöne Grüße aus Bremen wünscht
    SkyCircle
     
  2. Pegasus

    Pegasus Benutzer

    AW: Streaming mit On-Board-Sound?

    Da der Soundchip mit dem Datenstrom nichts zu tun hat, kanns daran nicht liegen.
    Du kannst auch streamen, wenn du gar keine Soundkarte im Rechner hast.

    Der Fehler liegt entweder in deinem Internetzugang (Router, Switch, NK) oder evtl. irgendwo am TCP/IP Protokoll. Ebenso kanns am Streamingprogramm liegen, dummerweise sagst du ja nicht, welches du benutzt.
     
  3. ForenKater

    ForenKater Benutzer

    AW: Streaming mit On-Board-Sound?

    Sehr wohl kann das was mit dem eingesetzten Soundsystem zu tun haben. Der Ton wird vom Linein abgegriffen, bzw von einem Soundkartenkanal. Wenn Du ohne Soundarte Streamst (vgl. SAM2), läuft das Prozessorseitig ab. OnBoard-Lösungen haben immer die Eigenart merkwürdigste Qualitäten beim Streaming auszugeben, oder aber auch beim LineOut. Wenn sich der Ton am Lineout anhört sagt das noch NICHTS über die Qualität der Aufnahmeschnittstellen aus. Nimm doch einfach eine kleine Soundblasterkarte, ne 4.1 reicht ja schon völlig.
     
  4. SkyCircle

    SkyCircle Benutzer

    AW: Streaming mit On-Board-Sound?


    Am Streamingprogramm liegt es nicht, ich habe sowohl mit SimpleCast als auch mit Shoutcast versucht zu senden, bei beiden das gleiche Ergebnis: Neben der Frequenzauslöschung scheinen sich teilbereiche des Streams zu wiederholen (Musik läuft tw. noch, obwohl der Stream schon 2-3 Minuten vorher abgeschaltet wurde) . Router ist ebenso unwahrscheinlich, da der erfolgreiche Test auf meinem alten System über die gleiche Internetanbindung bzw. die gleiche Technik lief...

    Bliebe also das TCP/IP-Protokoll (Wo kann da der Fehler liegen??) oder eben die Soundkarte... - muss ich bei der Auswahl der Soundkarte auf ein bestimmtes Merkmal achten, oder ist jedes Modell recht? Dachte bisher so an eine "TerraTec SoundSystem Aureon 5.1", liegt bei eBay bei etwa 12€ + Versand.
     
  5. Pegasus

    Pegasus Benutzer

    AW: Streaming mit On-Board-Sound?

    Hab nochmal nachgelesen. Sieht so aus, als wenn das wirklich die OnBoard karte ist.
    Also das OnBoard-System abschalten und ne andere rein. Am Protokoll kanns fast nicht liegen, da sonst niemand, den ich kenne, Probleme hat.

    Warum allerdings die Streamingdaten über die Soundkarte laufen, entzieht sich meiner Logik, aber damit kann ich leben :D

    BTW, Shoutcast ist kein Streamingprogramm, sondern ein Streamingserver. Du kannst höchstens mit dem Shoutcastplugin und Winamp getestet haben.
     
  6. ForenKater

    ForenKater Benutzer

    AW: Streaming mit On-Board-Sound?

    Die Terratec haben meistens eine merkwürdige Bedienoberfläche und kmische Einstellungen, da gab es bisher schon oft Probleme - ich empfehle nach wie vor Creative.
     
  7. quasimidi

    quasimidi Benutzer

    AW: Streaming mit On-Board-Sound?

    Moin,

    ich hab Probleme damit, das das was mit der Soundkarte etwas zu tun haben soll.

    Unser Streamerzeuger hat z.b. keine Soundkarte eingebaut und trotzdem kommt Musik raus...:)

    Daher folgende Fragen um den Fehler einzugrenzen:
    Wird die Musik im Rechner erzeugt oder über die Soundkarte (Line In) erfasst?

    Welcher Codec wird genutzt?

    Kann es sein das Shareware Tools genutzt werden um die Musik intern im Rechner zu bearbeiten (Totalrecoder fängt nach 3 min. z.B. stark an zu rauschen) ?

    Ich denke das man die Antwort nicht so pauschalisieren...

    mfg Michael
     
  8. ForenKater

    ForenKater Benutzer

    AW: Streaming mit On-Board-Sound?

    Sobald der Sound nicht von einer bestimmten Software erzeugt und von der selben verarbeitet / gestreamt wird (dann ohne Umweg über die Soundkarte), geht das über die Aufnahmekanäle der Soundkarte. Bums,aus,basta. Wiedergabe > WaveOut, Record > Stereo Mix/What You Hear > Master (wie auch immer), es läuft jedenfalls über den SOftwareausgang der Karte.
     
  9. quasimidi

    quasimidi Benutzer

    AW: Streaming mit On-Board-Sound?

    Sorry, das ich Dir da widerspreche.
    Ich hab das VAC (Virtual Audio Cable) als Klangerzeuger auf einen Server OHNE OnBoard oder gar eingesteckter Soundkarte installiert.

    Daher ja auch meine Frage nach der Konfiguration des Rechners und der Hinweis auf pauschalisierte Ausagen.

    Um zu testen ob es an der Soundkarte liegt, muss man ja nicht gleich loslaufen und sich eine neue kaufen.

    Einfach mal die Testversion von VAC installieren, diese als Soundgerät auswählen und mal checken was beim Hörer ankommt. Sollte der Fehler immer noch vorhanden sein, lässt sich die Soundkarte als Quelle ausschliessen.

    Es gibt mehrere Wege zu streamen..um mit Deinen Worten zu schliessen...

    Bums,aus,basta.

    Grüße aus Nord Neukölln, Berlin, Erde

    Michael
     
  10. Pegasus

    Pegasus Benutzer

    AW: Streaming mit On-Board-Sound?

    Wenn du gelesen hättest, dann hättest du mitgekriegt, das wir das schon hatten, das es ohne Soundkarte auch geht.
    Aber das Treibermodell von Windows leitet, sobald eine Soundkarte installiert ist, den Sound da drüber. Und bevor du hier rumbumst, solltest du erstmal alle Beiträge lesen.
     
  11. mr51127

    mr51127 Benutzer

    AW: Streaming mit On-Board-Sound?

    Wenn Du die Bitrate (kbps) änderst, tritt dieses Phänomen auch auf? Ich wurde schon mit vielen Problemen konfrontiert, aber sowas ist mir neu. Kann mir darunter nur vorstellen, dass Du eine zu kleine Bitrate eingestellt hast und der spacige Sound mit den dadurch entstehenden Komprimierungsartefakten zusammenhängt, wenn Du Deinen eigenen Stream von einem zweiten Rechner abhörst.

    Auch mit Onboard-Soundkarten kann man seine Sendungen in hervorragender Qualität abhalten, schließlich hat (fast) jede OnBoard-Soundkarte einen qualitativ einwandfreien LineIn-Anschluss. Was jedoch bei vielen OnBoard-Soundkarten kränkelt ist der Mikrofon-Anschluss. Das ist aber bei vielen Markensoundkarten ebenfalls der Fall.

    Übrigens Winamp mit Shoutcast-Plugin ist keine endgültige Lösung zum Streamen, aber für Probezwecke einigermaßen brauchbar. Ich sage dies deshalb, weil die meisten Technikprobleme beim Streaming in Verbindung mit Winamp bestehen.
     
  12. quasimidi

    quasimidi Benutzer

    AW: Streaming mit On-Board-Sound?

    Grüße nach Omicron,

    ich kenn Windows, hatte die Ehre einige MS Seminare mitmachen zu dürfen.
    Daher auch mein hinweis auf VAC da es sich als "Software Soundkarte" im System einbindet und man kann entscheiden ob man dies als Sounderzeuger nimmt. Man kann ja schließlich die OnBoard Karte im C_Mos Setup abschalten und das so probieren, da ich nicht denke, das das Problem daranliegt.

    Denn über das abschalten der Karte oder einen anderen Check des Systems, darüber habe ich in diesem Thread, den ich übrigends komplett gelesen habe, nichts entdeckt.

    Ist auch egal, Ihr werdet den Fehler schon finden..

    gruss aus dem Sendegebiet Berlin
    Michael
     
  13. ForenKater

    ForenKater Benutzer

    AW: Streaming mit On-Board-Sound?

    Oh, ein Herr MC**. Das sind mir die liebsten ;) Zurück zu Heise mit Dir, Troll :p ;) He, nur ein Scherz.. Also: In obenstehendem Beitrag schrieb ich:

    was wohl Deinem VAC entspricht. Von diesem Fall sprechen wir aber nicht. Wir wollen wissen: Liegt es am OnBoard-Chipset. Und das können wir wohl so gut wie mit "Ja" beantworten.
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen