1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Streaming über Playlist nicht möglich – sc_trans verbindet sich nicht zu sc_serv

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von Invocation, 02. September 2007.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Invocation

    Invocation Benutzer

    Hi zusammen,

    bin beim einrichten einer Playlist für den Shoutcast-Server über ein "kleines" Problem gestolpert. Das ganze läuft auf einem VRoot-Server (Suse 9.2), auf dem via Shoutcast und SAM bereits gestreamt werden kann.

    Um eine Playlist laufen zu lassen, habe ich mir einige how-to´s im Netz angesehen und sc_trans konfiguriert.
    Die Playlist selbst ist auch erfolgreich erstellt worden, die Port sowie Passwort Einstellungen in den beiden Config-Dateien stimmen auch überein.

    Dennoch kann sich sc_trans offensichtlich nicht zu sc_serv verbinden.

    Hier daher zunächst das Log von sc_trans:

    Code:
    :/home/shoutcast/trans # ./sc_trans_linux
        *******************************************************************************
        ** TRANScast Distributed Network Audio Content Provider
        ** Copyright (C) 2000 Nullsoft, Inc.  All Rights Reserved.
        ** Use "sc_trans filename.conf" to specify a config file.
        *******************************************************************************
        <09/01/07@20:56:38> [TRANSCast] DNAS/posix v0.400-LAME (Mar  4 2003) starting up...
        <09/01/07@20:56:38> [MAIN] PID: 15614
        <09/01/07@20:56:38> [MAIN] Loaded config from sc_trans.conf
        <09/01/07@20:56:38> [MAIN] Loading playlist (playlist.lst)
        <09/01/07@20:56:38> [MAIN] Found (186) entries in playlist
        <09/01/07@20:56:38> [MAIN] Playlist decoder thread starting
        <09/01/07@20:56:38> [MAIN] Streaming thread starting
        <09/01/07@20:56:38> [DECODE] Opened Peter Maffay - Über sieben Brücken mußt du geh'n.mp3
        <09/01/07@20:56:38> [STREAM] Creating stream socket
        <09/01/07@20:56:38> [STREAM] Error connecting to stream host [waiting 10s]
        <09/01/07@20:56:38> [CONFIG] WARNING: No InputSamplerate defined, assuming 44100!
        <09/01/07@20:56:38> [CONFIG] WARNING: No InputChannels defined, assuming 2!
        mpg123: Can't rewind stream by 173 bits!
        <09/01/07@20:56:38> Warning: input file samplerate is 1077601328 Hz, must be 44100!
        <09/01/07@20:56:38> [DECODE] Opened Heiland_-_Schuld_.mp3
        <09/01/07@20:56:39> [MAIN] Title Update Failed
        <09/01/07@20:56:48> [STREAM] Creating stream socket
        <09/01/07@20:56:48> [STREAM] Error connecting to stream host [waiting 10s]
        <09/01/07@20:56:56> [MAIN] SIGINT; exiting!
    

    Dazu die sc_serv config (ohne Kommentare):

    Code:
        ; sc_serv.exe sc_leet.conf
        MaxUser=100
        Password=XXXXXXXXXXXXXXXXXXX
        PortBase=11608
        ;LogFile=sc_serv.log
        RealTime=1
        ScreenLog=1
        ShowLastSongs=10
        ; TchLog=yes
        WebLog=yes
        W3CEnable=Yes
        W3CLog=sc_w3c.log
        SrcIP=127.0.0.1
        DestIP=any
        Yport=80
        NameLookups=0
        ; RelayPort=8000
        ; RelayServer=192.168.1.58
        AdminPassword=XXXXXXXXXXXXXXXXX
        AutoDumpUsers=0
        AutoDumpSourceTime=30
        ; ContentDir=/home/mp3/
        ; IntroFile=c:\intro%d.mp3
        ; BackupFile=C:\intro%d.mp3
        TitleFormat=Test Radio
        ; URLFormat=http://www.server.com/redirect.cgi?url=%s
        PublicServer=never
        AllowRelay=No
        AllowPublicRelay=No
        MetaInterval=32768
        ; ListenerTimer=600
        generated via the web
        ; BanFile=sc_serv.ban
        ; RipFile=sc_serv.rip
        ; RIPOnly=No
    

    Und hier auch noch die config von sc_trans.

    Code:
        PlaylistFile=playlist.lst
        ServerIP=127.0.0.1
        ServerPort=11609
        Password=XXXXXXXXXXXx
        StreamTitle=My Gay Son
        StreamURL=http://mygayson.com
        Genre=genres go here
        LogFile=sc_trans.log
        Shuffle=1
        Bitrate=128000
        SampleRate=44100
        Channels=2
        Quality=1
        CrossfadeLength=8000
        UseID3=0
        Public=1
        AIM=AIMHandle
        ICQ=
        IRC=shoutcast
    

    Bin über jede Hilfe dankbar :)
     
  2. Invocation

    Invocation Benutzer

    AW: Streaming über Playlist nicht möglich – sc_trans verbindet sich nicht zu sc_serv

    Ok,

    nachdem ich nun durch Zufall das Log des SC Servers durchgegangen bin, ist mir durch Zufall ein Eintrag aufgefallen:

    Code:
    <09/02/07@13:00:08> [source] invalid password from 127.0.0.1
    
    Trotz Änderung der Ports sowie des Passworts konnte ich das Problem nicht lösen.
    Durch Zufall bin ich dann auf diese Seite gestoßen.

    Demzufolge könnte es sich durchaus um ein nicht lösbares Problem mit sc_trans selbst handeln.

    Lösung: Nimm ein anderes Programm :(
     
  3. Invocation

    Invocation Benutzer

    AW: Streaming über Playlist nicht möglich – sc_trans verbindet sich nicht zu sc_serv

    Ok,

    selbes Problem hatten wir ja schon mal mit SAM. Es waren die Ports, die offensichtlich, an denen es hing.
    Nachdem wir diese nun geändert haben, läuft alles :)

    Tipp für Alle: Unerklärliche Probleme mit dem Passwort bei Shoutcast lassen immer sehr stark auf ein Port-Problem deuten.
     
  4. TheNightHawk

    TheNightHawk Benutzer

    AW: Streaming über Playlist nicht möglich – sc_trans verbindet sich nicht zu sc_serv

    Aus Deiner Config sc_serv

    PortBase=11608

    Aus Deiner Config sc_trans

    ServerPort=11609

    Ändere bitte den Serverport in der sc_strans auf 11608

    Gruß TheNightHawk
     
  5. Invocation

    Invocation Benutzer

    AW: Streaming über Playlist nicht möglich – sc_trans verbindet sich nicht zu sc_serv

    Hi,

    danke für den Tip :) Hatte vergessen zu erwähnen, dass ich dies selbstverständlich schon versucht hatte, d.h. hatte es mit 11607, 11608 und 11609 versucht.

    Keine Chance... Es ging letztlich wirklich nur mit einer Änderung der Ports.
    Gleiches Problem hatte ich auch hier, bloß betraf es da die Verbindung mit SAM.
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen