1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Streamtranscoder – bisher ungelöstes Problem

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von MattCrisco, 17. Dezember 2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MattCrisco

    MattCrisco Benutzer

    Hallo gemeinde,

    wir haben uns jetzt schon des oefteren verschiedene threads zu dem streamtranscoder durchgelesen wo wir auch auf unser problem gestossen sind, nur zu keiner loesung...

    *** Could not run liblame test program, checking why...
    *** The test program compiled, but did not run. This usually means
    *** that the run-time linker is not finding liblame or finding the wrong
    *** version of liblame. If it is not finding liblame, you'll need to set your
    *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
    *** to the installed location Also, make sure you have run ldconfig if that
    *** is required on your system
    ***
    *** If you have an old version installed, it is best to remove it, although
    *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
    configure: WARNING: LAME not installed
    checking for faacEncOpen in -lfaac... no
    configure: WARNING: FAAC not installed, AAC encoding DISABLED.
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating liboddcast/Makefile
    config.status: executing depfiles commands

    wir haben keine ahnung was in /etc/ld.so.conf diese datei reinkommen soll! :wall:

    bitte helft uns das Problem zu loesen...

    ThX schonmal

    MfG MattCrisco
     
  2. ChaotY2k

    ChaotY2k Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    also mangels genauer Angaben Deinerseits kann ich Dir nicht viel helfen...

    Fragen:
    - liblame bzw. lame installiert?
    - welche Distri?
    - Welche Version?
    - aktuelle Updates drauf?

    meine /etc/ld.so.conf:
    Code:
    /usr/local/lib
    //usr//lib/opengl/xorg-x11/lib
    /usr/i686-pc-linux-gnu/lib
    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1
    /usr/lib/gcc/i686-pc-linux-gnu/3.4.6
    /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6
    /usr/lib
    /usr/lib/openmotif-2.2
    /usr/qt/3/lib
    
    such doch mal wie das file der liblame heissen sollte und ob Du die auf deiner kiste findest.

    Für gentoo gibts z.b. ein eigenes Paket:
    * media-sound/lame
    Latest version available: 3.96.1
    Latest version installed: [ Not Installed ]
    Size of files: 1,226 kB
    Homepage: http://lame.sourceforge.net
    Description: LAME Ain't an MP3 Encoder
    License: LGPL-2.1
     
  3. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Wenn es ein Suse ist, musst du LAME selbst kompilieren, da der Transcoder mit dem fertigen Paket ein Problem jhat. Wenn du ein richtiges Linux hast (z.B. Gentoo, Debian, Fedora), gibts passende Pakete zu liblame und auch libflac
     
  4. MattCrisco

    MattCrisco Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    also ich habe debian auf meinem root installiert und habe die neuste lame version selbst compiliert. es ist von allem die aktuellste version drauf.

    MfG Blizzard
     
  5. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Und wenn du uns jetzt noch erzählst, welches Debian und welche Version des Transcoders (was auch bereits schonmal nachgefragt wurde), kann dir vielleicht auch jemand helfen.

    Und wieder stellt sich die Frage, warum ein Hilfesuchender nichtmal auf Nachfrage die relevanten Infos gibt.
     
  6. DJMasterhaze

    DJMasterhaze Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Also die Kugel sagt: streamTranscoderv3 ist nicht installiert, diese version brauch die aktuellsten LibLame & libflac.

    Bin der Meinung das er eine veralteten StreamTranscoder von Odsock verwendet.

    Für Debian gibt es sogar ein Packet für den StreamTranscoderv3, wo alles drinnen ist.
     
  7. MattCrisco

    MattCrisco Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    mh wie sehe ich welche debian distri und version ich habe? sry ;/ streamtranscoder habe ich die neuste von der seite gezogen.

    MfG Blizzard
     
  8. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Erstma, wenn du nicht weisst, welches Betriebssystem du einsetzt, solltest du schnell davon Abstand nehmen, einen eigenen Server zu betreiben.
    Denn selbst, wenn du nicht weisst, wo du nachsehen musst, hast du einen Vertrag unterschrieben, das diese Angaben enthält.

    Und Debian ist die Distribution.

    Da steht die Versionsnummer drin.
    Und beim Streamtranscoder gibt es streamTranscoderv3 und streamTranscoder. Ist es eigentlich so schwer, den kompletten Dateinamen der heruntergeladenen Datei per Copy&Paste hier reinzuposten?

    So nebenbei werfe ich mal einen Link zu einem Zitat von mir ein, dass das Thema "Rootserver" und "Anfänger" recht gut widerspiegelt.

    http://community.de.selfhtml.org/zitatesammlung/zitat211
     
  9. MattCrisco

    MattCrisco Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    StreamTranscoderV3 ist es die neuste davon jhabe ich doch gesagt!

    Distri:

    3.1 ... mehr steht in dem file net supa wa? ^^

    MfG Matt
     
  10. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Mehr interessiert ja auch nicht. Oder was willst du noch drinstehen haben, wenn du die Versionsnummer wissen willst?

    mach mal folgendes
    Dann kompilierst du nochmal den Streamtranscoder. Wenns noch Probleme gibt, die genaue Bildschirmausgabe posten

    @DJMasterhaze
    hast du ne Quelle für das Paket? Ich hab leider nur eins für Suse gefunden. Würd ich dann in meine Liste aufnehmen. Dann spar ich mir die Arbeit, selbst ein Paket zu bauen ;)
     
  11. DJMasterhaze

    DJMasterhaze Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem


    Ja habe ich
    http://rpmseek.com/rpm-pl/streamtranscoderv3.html?hl=de&cs=Transcoder:pN:0:0:0:0

    und ein Debug auch noch
    http://rpmseek.com/rpm-pl/streamtranscoderv3-debuginfo.html?hl=de&cs=Transcoder:pN:0:0:0:0

    Aber Direkt hier ist der Link zu der Hauptseite http://search.rpmseek.com
    Also vieles was ich für meinen Server benötige finde ich meistens da.

    LG & Servus
     
  12. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Das sind die Suse-pakete, die ich gefunden hab. Und sowas mit Alien einzuspielen ist immer ein Glücksspiel.
    Ich meinte eher ein deb-Paket mit Abhängigkeitsprüfung. Mal sehen ob ich doch bei gelegenheit eins für Etch baue
     
  13. MattCrisco

    MattCrisco Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    E: Konnte Paket liblame0 nicht finden
    server130:/home/cradio/transcoder# apt-get install libfaac0 liblame-dev libfaac-dev
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    E: Konnte Paket libfaac0 nicht finden
     
  14. DJMasterhaze

    DJMasterhaze Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem


    Ich hatte meine da auch weg, die links hatte ich noch von damals da waren noch .deb pakete mit drinnen, es gibt die aber noch auf einer Debian Seite wo es Inoffziell oder so ähnlich heist, aber leider weis ich die Adresse dazu nicht mehr.
     
  15. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    @Matt
    mach mal die Datei /etc/apt/sources.list in irgendeinem Editor auf und füge folgende Zeilen dazu
    Anschliessend ein
    Danach solltest du liblame und libfaac installieren können.
    Eigentlich würde der Eintrag von debian-multimedia reichen, aber die anderen Quellen bieten auch viele feine Sachen an ;)


    @DJ
    weder auf Debian-Multimedia.org noch auf Debian-unofficial.org hab ich was gefunden. Wenn ich irgendwo was finde, werd ichs aber erzählen ;)
     
  16. MattCrisco

    MattCrisco Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Also erstmal herzlichen dank :D an alle die mir geholfen haben ;) es geht. Jetzt wollte ich mal noch fragen ob das normal ist das der sowas von dermassen krass CPU leistung frisst ^^.

    MfG MattCrisco
     
  17. Pegasus

    Pegasus Benutzer

    AW: Streamtranscoder – bisher ungelöstes Problem

    Dein Rechner muss in Echtzeit einen Stream umrechnen. Sowas frisst enorm Prozessor.
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen