1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Welche PC-Leistung für SAM Broadcaster?

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von lukass2000, 29. Februar 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. lukass2000

    lukass2000 Benutzer

    Hi Experten!
    Bis vor drei Monaten habe ich mit SAM 4.2.2 und einem altem PIII mit 1GHz, 1GB Ram, SB Live, Win XP gestreamt und alles lief perfekt.
    Leider hat sich dieser PC verabschiedet und ich habe mir einen neuen PC gebaut.
    Hat eine AMD Athlon 4,2GHz Dualcore CPU, 3GB Ram, Terratec Aureon, Windows XP und alles hängt und ruckt.
    Dacht mir dann okay, mach ich mal ein Update auf 4.9.2, damit sollte doch zumindest mal das ergoogelte Dual Core Problem behoben sein. Bilde mir auch ien, das es minimal besser ist.
    Aber selbst beim normalen überblenden von einem Track zum nächsten habe ich meist einen kurzen hänger.
    Special Audio meinte das System sollte leistungsmäßig absolut reichen.
    Das kann doch nicht sein, oder???
    Wieso lief auf einem viel leistungsschwächerem System alles besser?
    Welche hardware verwendet Ihr für SAM?
    Würde eine Intel CPU einen Vorteil haben?
    DANKE!
    LG
     
  2. Superradiotabea

    Superradiotabea Benutzer

    Hallo Lukas,

    das hört sich nach einem Treiber Problem an. Denn die Konfiguration ist ausreichend. Überlege mal was Du alles verändert hast. Bei Überblendungen benötigen wave Datein zwar weniger CPU als zum Beispiel MP3, aber das dürfte auch hier nicht der Fall sein, denn Deine Leistung (3 GB !!!) erscheint mir ausreichend. Schau mal im Task Manager bei Überbledungen ob Deine CPU sehr hoch ist, wenn nicht, dann liegts vermutlich am Treiber. Aber wie gesagt. Deine Leistung müsste dafür eigentlich ausreichend sein ! :thumpsup: Der Sam läuft auch stabil auf weniger Leistungsstarken Systemen. Schau mal ob Deine Treiber alle Okay sind !!!

    Andere Frage: Welche Programme laufen auf Deinen PC noch ? Machst Du zum Beispiel Videobearbeitung noch auf dem Radioautomationsrechner ? Ein Playout System sollte immer so schlank wie möglich sein ! Denn schlank ist trollig gut !:thumpsup:


    Liebe Grüße von Superradiotabea ! :thumpsup:
     
  3. Oldwood

    Oldwood Benutzer

    Moinsen,
    an Deiner Hardwarekonfiguration sollte es zunächst erst ein mal nicht liegen. Allerdings gehe ich davon aus, dass Du auch alle Motherboardtreiber installiert hast, insbesondere den AMD-DualCore-Treiber.

    Wenn Du schreibst, alles ruckelt und hängt, verstehe ich das als wahrnehmbare (hörbare) Ruckler (Aussetzer) beim Abspielen der mp3's. Das wiederum lässt auf sehr hohe Latenzen in der Audiowiedergabe schliessen. Auch kann es sich um sog. Dropouts handeln, die entstehen, wenn der Rechner beim Ausspielen zusätzlich mit etwas anderem beschäftigt ist. Insofern ist der Tipp von Tabea absolut richtig: Schau in den Taskmanager und suche den Prozess, der viel Leistung nimmt, wenn die Ruckler entstehen.

    Alle Treiber up to Date zu haben, versteht sich von selbst. ;)
     
  4. lukass2000

    lukass2000 Benutzer

    Hi Leute!
    Das die Treiber am neuestem Stand sind versteht sich :)
    Den AMD DualCore Treiber hat mir Google verraten, also auch installiert.
    Hauptsächlich und extrem störend ist der Hänger wenn von einem Track auf den anderen gefaded wird.
    Da kann schon mal sein, das SAM eine knappe Sekunde hängt.
    Selten, aber es kommt vor das auch kurz während dem normalem abspielen ein "Hacker" hörbar ist.

    Es sieht fast so aus, als ob der PC oder auch SAM beim überblenden mit irgendetwas anderm extrem beschäftigt ist?

    Das System ist übrigens komplett neu installiert.
    Habe nur SAM, MP3Gain, MP3Tag, WinAMP und Firefox installiert.
    Es läuft aber keines der Programm im Hintergrund, habe ich alles deaktiviert.
    Die CPU Auslastung ist so zwischen 12 und 15% beim normalem Abspielen, beim Überblenden der Tracks steigt die CPU Auslastung auf 37 - 41%.
    Sonst läuft im Taskmanager nichts auffalendes, außer ca. 85% Leerlaufprozesse :)

    Hatte anfangs mal auf die Soundkarte getippt, hat mir der Händler aber freundlicher weise ausgetauscht.
    Vor allem müßte dann doch ein Unterschied sein, ob DSP an oder aus ist, oder verwendet SAM die Soundkarte auch wenn ich nicht über das externe Mischpult fahre?

    DANKE!
     
  5. Sven76LDK

    Sven76LDK Benutzer

    Hallo Lukas,

    sind Deine mp3-Files auf einer USB-Festplatte, oder einem Netzwerklaufwerk gespeichert?
    Ich hatte ein ähnliches Problem auch Anfangs mit meiner Hardware:
    Die USB-Festplatte (wo meine gesamte Musiksammlung gespeichert war) ging an einem Rechner immer in Stand-By und brauchte ewig zum wieder hochfahren was zu solchen Aussetzer führte.
    An einem anderen System mit nahezu identischer XP-Konfiguration lief es ohne Aussetzer. Auch lief die Festplatte direkt angeschlossen am Mainboard (ohne externes USB-Gehäuse) einwandfrei.
    Hieraus ziehe ich für mich folgende Erfahrung: Manchmal vertragen sich die USB-Chipsätze externer HD nicht immer ideal mit den Chipsätzen der Mainboards.

    Ich kenne mich mit SAM nicht aus, aber denke das es auch in SAM eine Möglichkeit gibt die internen Buffer (Pre-Load) so hoch zu setzen, das die gesamte mp3 in den RAM geladen wird?
    Wäre doch bestimmt einen Versuch wert?

    Gruß
    Sven
     
  6. Superradiotabea

    Superradiotabea Benutzer

    Hallo Lukas,

    jetzt wollte ich während meiner Arbeit in der Redaktion mal schnell reinschauen und Dich fragen, hast Du das Problem schon näher eingrenzen können ? :thumpsup:
     
  7. Gutz

    Gutz Benutzer

    Im Spacial Audio Forum habe ich gelesen, mann solle den implementierten Mp3 Codec gegen einen anderen austauschen, Lame etc.
    Der mitgelieferte Codec lastet im Streambetrieb die CPU Kerne zu hoch aus, was anscheinend ein Phänomen auf AMD Dual-Core Prozessoren sein soll.
    Beobachte mal während des streamens deine CPU Auslastung.

    http://support.spacialaudio.com/for...&t=22376&sid=1df214492a834af28907347c613cb84e
     
  8. Superradiotabea

    Superradiotabea Benutzer

    :)
    Eine gute Idee von Hern Gutz !:thumpsup:

    Wie gesagt: mp3 benötigt mehr Leistung als eine wave Abtastung. Probier mal folgendes aus Lukas:

    Lade in den Sam einige reine wave (PCM) Dateien ! Wenn es ohne Probleme läuft, dann haben wir die Ursache gefunden !
    Wenn es bei wave Dateien dort ebenfalls zu Aussetzer kommt, dann haben wir das Problem schon mal eingekreist !. :thumpsup:
     
  9. Gutz

    Gutz Benutzer

    So ist das nicht ganz richtig.
    Wenn Lukas vor hat im mp3 zu streamen, nutzen ihm die wave Files auch nichts.
    Wemm mp3 am Ende raus kommen soll muss auch in mp3 encodiert werden, was nunmal die Aufgabe des Encoders ist (oder ogg, aac usw.), auch wenn man ihn mit wav Files füttert.
    Da der Encoder, den Sam mitliefert aber Probleme mit Dual Cores macht rät man im Spacial Audio Forum dazu einen anderen Encoder hier zu zu verwenden.
    Natürlich ist die Wahl nicht auf Lame beschränkt, hier kann jedes nach seinem Gusto wählen.
     
  10. Superradiotabea

    Superradiotabea Benutzer

    Hallo Gutz,:)

    das ist nicht ganz richtig. Du musst unterscheiden zwischen: Streaming - Live Inhalte werden ins Netz übertragen und dem Abtasten von mp3 Audiofiles. Letzteres bedeutet, dass ein Rechner mit der mp3 Abtastung und Entschlüsselung mehr Kapazitäten benötigt als bei wave Dateien. Insofern würde es schon Sinn machen, den Sam mit wave Dateien zu füttern. :thumpsup: Das Endstreaming als Liveeinsatz bleibt davon unberührt. :thumpsup: Somit könnte man die Fehlerquelle eingrenzen !
     
  11. MADxHAWK

    MADxHAWK Benutzer

    Hallo zusammen,

    prinzipiell läuft der SAM 4.2 auch auf Multicore Systemen, bei mir auf einem Phenom x2 Quadcore mit 3,4 GHz unter Win7 64bit Ultimate. Allerdings muss hier der lame acm codec verwendet werden.
    Ein Problem ist, dass Sam standardmäßig immer nur einen Core nutzt, auch in der Version 4.9.x. Hier kannst du im Taskmanager SAM alle Kerne zuweise, was jedoch bei jedem Start manuell wiederholt werden muss.
    Eine weitere fehlerquelle wäre noch die Datenbank, da SAM alle seine Titel in einer eigenen Datenbank verwaltet, könnte auch hier ein Problem vorliegen (langsame Datenbank).

    -MAD
     
  12. dj-rainer-h

    dj-rainer-h Benutzer

    Recht hat er, der MADxHAWK. Deshalb ist der Standard bei den neuen SAM-Versionen auch der Lame-Encoder. Der macht bei AMD-Multicore-Systemen keine Probleme mehr. Die Datenbank wird es eher nict sein, da bei mir direkt nach der ersten Installation auf dem AMD schon das Problem auftrat, noch bevor, die Datenbank gefüllt wurde...
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen