1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Windows 7: Sound verzögert

Dieses Thema im Forum "Studio- und Sendertechnik" wurde erstellt von nicolai, 10. August 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. nicolai

    nicolai Benutzer

    Ein Problem, das viele sicher kennen: Über den Line In Eingang kommt kommt bei mir mit windows 7 der Sound etwa mit einer halben Sekunde verzögert auf die Kopfhörer. Unter XP war das nicht. Wie ändert man das? Liegt das an der Soundkarte (Realtek onboard)?

    Danke an alle!

    Nicolai
     
  2. divy

    divy Benutzer

    Ich benutze die Onboard-Karte zwar nicht. Allerdings formulierst Du Deine Frage schlecht oder machst wirklich einen lustigen Fehler. Auch ich bekomme über den Line-In-Eingang kein Signal auf den Kopfhörer. Nur über den Kopferhörerausgang. Stöpselst Du falsch ein, oder formulierst Du falsch?

    Wenn Du hingegen meinst, dass bei der Wiedergabe und korrekter Verbindung des Kopfhörers das Signal später auf dem Kopfhörer ankommt als es nach der grafischen DArstellung sein sollte, hm, früher konnte man solche Dinge mit den Puffereinstellungen korrigieren. Evtl. kannst Du das auch mit der Installation der asio-Treiber korrigieren. Google mal nach asio4all.
     
  3. nicolai

    nicolai Benutzer

    Danke, ich habe natürlich falsch formuliert, konkret: Ist ist alles vorschriftsmäßig gestöpselt und das Signal vom Line-In Eingang kommt verspätet am Ausgang raus, etwa so wie mit Hinterbandkontrollle bei der Tonbandmaschine. So fällt es schwer, bei der Aufnahme flüssig zu sprechen. asio4all habe ich auch schon gefunden, angeblich kann die Latenz damit runtergefahren werden. Mal probieren, ich dachte nur, man könnte es einfach einstellen, irgendwo in windows oder bei der Soundkarte. Wie gesagt, bei XP ist dieser Effekt nie aufgetreten.
     
  4. divy

    divy Benutzer

    Bei Win7 kommst Du mit dem Rechtsklick auf das Lautsprechersymbol rechts unten in die Audioeinstellungen.Je nach Karte kannst Du dort dann auch die Puffer einstellen. Allerdings, wäre es ein Problem der Latenzen, dann hättest du vermutlich auch Artefakte in der Aufnahme. Ging mir jedenfalls so. Ist denn auch die grafische Darstellung verzögert oder nur die Wiedergabe des Audio? Passiert das nur bei der Aufnahme, oder auch wenn Du irgendeine Audiodatei abspielst?

    Was mich wundert: Warum schließt Du den Kopfhörer nicht an den Vorverstärker des Mikros an?
     
  5. codo

    codo Benutzer

    Nein, bei einer onboard RealDreck Soundkarte kann man mit einem Rechtsklick auf das Lautsprechersymbol leider nichts erreichen.
    Das Problem ist Methode.
    Windows 7 zusammen mit RealDreck onboard Soundkarten verursacht massive Aufnahme-Audioprobleme.

    Installiert man XP auf der gleichen Hardware funktioniert alles wunderbar. Komisch? Nein, meiner Meinung nach gewollt.
    Dieses ausgeklügelte System von fehlenden Treibern (ASIO) und schlechten Möglichkeiten der Aufnahme dient wohl dazu um Kopien von Musik zu erschweren. Ein Windows 7 Rechner mit einer onboard RealDreck Soundkarte ist zur standardmäßigen Audioaufnahme on the fly so gut wie nicht geeignet.

    Beispiele:
    - Um eine interne Quelle mit einem älteren Adobe Audition aufzeichnen zu wollen (z.B. Webstream Mitschnitt) ist erst die neuste Version von Adobe Audition zu installieren damit das funktioniert. Installiert man XP auf dem gleichen PC klappt es.

    - Der Stereomixer-Fader, früher im Audiomixer der Soundkarte unter Aufnahme zu finden, muss nun erst mal "gebaut" werden.
    Wenn man das nicht weiß wie man unter der Systemeinstellung den Stereomixer erst mal "bauen" muss um ihn hinzufügen zu können, wird man keine Aufnahmen eines internen Signals machen können.

    - Dann der Major-Bug: Der Audio-Mixer selbst, der kein Mixer mehr ist.
    Angenommen man nimmt mehrere Signale gleichzeitig auf. Dann konnte man früher die Mithörlautstärke der einzelnenQuellen über der jeweiligen Fader des Windows Lautstärke Mixers regeln. Das geht mit Windows 7 nicht mehr!

    Die graue Linie über den Fadern verhindert das.

    Was diese graue Linie da soll, und welche Intention der Programmierer dabei hatte, ist mir völlig unklar. Sinnlos.

    Regelt mal eine leise Quelle z.B. laut um sie besser hören zu können als eine andere (eh schon laute) Quelle,
    wird immer auch automatisch der Summenregler durch diese ominöse graue Linie automatisch mit ganz nach oben geschoben.
    Die Abhöre wird dadurch brüllend laut, ein sinnvolles Arbeiten wird unmöglich.

    Das passiert auch wenn man einen internen Stereomix mit 0 dB aufzeichnen möchte.
    Um das zu erreichen, muss man nämlich auch den Fader der Quelle im Audiomixer ganz hoch ziehen.
    Was zu Folge hat, dass auch der Summenfader bis auf die Maximalstellung folgt, und das Gesamtsignal brüllend laut mit Maximalpegel über die Abhöre/Kopfhörer ausgegeben wird.
    Sinnlos zu erklären das, das die Funktion eines Mixers sabotiert.

    Also mach Dir nicht allzu viel Hoffnung dein Latenzproblem der RealDreck onboard Soundkarte unter Windows7 in den Griff zu bekommen. Diese Kombination ist aus Prinzip so grottig zusammengestellt. Der PC dient einzig und allein dazu gekauftes Audiomaterial wieder zugeben also abzuspielen. Aufnehmen ist dort seit Windows 7 quasi "herausprogrammiert" worden. (Seit Vista schon)

    Die einzige Möglichkeit, die sich bietet, ist Geld in die Hand zu nehmen und mit externer Hardware nachzurüsten und eine Soundkarte mit eigenen (ASIO) Treibern und eigenem Audiomixer nachzukaufen.
    Denn weder RealTek noch Microsoft bieten aktuell verbesserte Treiber, oder sonst irgendeine Lösung für all diese Probleme an.

    Die Musikerforen sind voll mit flennenden und fluchenden Hobbymusikern, die ihren XP-Rechner auf Windows 7 umgestellt haben.
    Eine ziemliche Unverschämtheit, denn bei einem Betriebssystem-Update erwartet man eine Verbesserung von Leistung.
    Für die Audioaufnahme unter Windows 7 mit Bordmitteln, ist aber leider das Gegenteil der Fall.

    Wer jetzt mit seinem XP-Rechner glücklich ist und alle Audiosoftware darauf stabil und zuverlässig laufen hat,
    sollte die Finger von Windows 7 lassen wenn er auf die onboard Soundkarte angewiesen, oder damit zufrieden ist.
    Sonst heißt es evtl. Software und Soundkarte nachkaufen damit wieder alles so läuft wie früher.


    Gruß Codo
     
    Hefeteich und divy gefällt das.
  6. Nobier

    Nobier Gesperrter Benutzer

    Du benötigst halt eine Karte mit ASIO Support (keine ASIO Emulation).
     
  7. Ohrenkneifer

    Ohrenkneifer Benutzer

    Wieder so ein Beispiel geplanter Obsoleszenz!

    An dieser Stelle möchte ich mich aber erst einmal den anderen Teilnehmern vorstellen. Bestimmt ist Einigen hier ja schon aufgefallen, dass ich hier den einen oder anderen Kommentar hinterlasse. Ich bin seit einigen Jahren hier "stiller Mitleser" und seit ich aus einem Nachlass an einige Gerätschaften aus einem Rundfunkstudio gekommen bin, die ich damals schon zum Wegschmeißen zu schade fand, auch an dieser Materie interessiert. Mit Radio hatte ich schon seit meiner Jugend immer was zu tun. Allerdings eher die Reparatur und Restauration älterer Geräte aus der Zeit, in der ein Radio noch ein Möbel war. Das Verständnis um diese Technik hatte ich mir damals, in einer Zeit ohne Internet, in mühevoller Kleinarbeit meist selbst beigebracht. Wenn ich mich hier umschaue, interessiert mich aber weniger der technische Bereich, als eher die Chronologie des Rundfunkwesen in Deutschland, Europa und der Welt und mit Spannung und Freude über die vielen Hörbeispiele verfolge ich auch die Diskussionen hier.

    Doch zurück zum Thema: Mir ist nach der Installation von Windows 7 auf einem Rechner mit Real-Tek-Soundchip aufgefallen, dass auch die Wiedergabe über Drittprogramme nicht mehr funktioniert. Konkret geht es hier um die Wiedergabe über das Programm "Radio-Player-Pro", das unter Windows-XP wunderbar funktioniert. Mir scheint, als wird die Musik nur noch in Mono und sehr schlechter Qualität (ähnl. 64 kb/s) ausgegeben. Nach einer Lösung zu suchen, habe ich inzwischen aufgegeben und habe nun einen Rechner mit entsprechender Audiokarte und ASIO-Treiber und das Problem hat sich nach Deaktivierung des Onboardsound erledigt.

    Allen liebe Grüße aus Dortmund

    Der Ohrenkneifer.
     
  8. nicolai

    nicolai Benutzer

    ...wer jetzt mit seinem XP-Rechner glücklich ist und alle Audiosoftware darauf stabil und zuverlässig laufen hat,
    sollte die Finger von Windows 7 lassen wenn er auf die onboard Soundkarte angewiesen, oder damit zufrieden ist.
    Sonst heißt es evtl. Software und Soundkarte nachkaufen damit wieder alles so läuft wie früher.


    Gruß Codo[/quote]

    Vielen Dank für deinen erhellenden und konstruktiven Beitrag. Leider war ich eben mit meinem XP-Rechner nicht mehr glücklich, da er einfach für alles mögliche einen zu schlappen Prozessor hatte. Das ist jetzt anders, aber vieles andere - wie geschildert - eben auch.

    Ich hab mir das für meine momentanen Bedürfnisse zwar jetzt so einigermaßen zurechtgeschustert, aber für vernünftige Audiobearbeitung etc. ist das natürlich alles Mumpitz. Wenn ich mir jetzt eine ordentliche Soundkarte zulege, ist mein geschildertes Problem (Verzögerung) dann und viele weitere (hoffentlich) dann trotz windows 7 zu beseitigen? Oder sollte man von Audiobearbeitung und -produktion generell absehen, wenn man windows 7 -Benutzer ist?

    Danke an alle!

    Nicolai
     
  9. divy

    divy Benutzer

    Mache Dir da keine Sorgen, ich betreibe Win7 mit einer ziemlich ordinären USB-Karte und es funktioniert ohne Probleme. Habe auch schon ein 25-Minuten-Feature drauf produziert. Für längere Stücke ziehe ich dennoch die Mitarbeit mit Audioprofis im Studio vor, das hat aber nichts mit dem OS zu tun.
     
  10. codo

    codo Benutzer

    Ja wie oben gesagt.
    Mit einer externen USB-Soundkarte hört der Spuk auf.

    Evtl. ist auch Platz für eine PCIe in einem freien Slot?
    Aber das ist ja auch schon fast wieder out. Da die externe Box einfach bessere Anschlußmöglichkeiten bietet.
    Wie echtes XLR und 42 V Phantomspeisung, oder einen ordentlichen 6,3 mm Klinkenstereobuchsenanschluß für Kopfhörer.

    Im BIOS kann man dann die onboard RealTek HD (High Definition angeblich, ja!?) getrost ausknipsen.
    Die verbraucht nur sinnlos Strom und "kostet" auch noch eine Neue. *grummel*
    Danke, schöne Grüße nach Redmond und and die ganze DRM Shice.


    Gruß Codo
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen