Shoutcast-Server: Bufferproblem


Status
Nicht offen für weitere Antworten.
#1
Hallo!

Umgebung:
Linux, Debian 3.0rc1-Root Server, 100MBit Port, ausser Ersetzung von inetd durch xinetd keine Änderungen, Shoutcast Server 1.9.4

Habe ein kleines Problem:
Bei uns ist es am buffern ohne Ende. Serverneustart, Shoutcast-Neuinstallation auf dem Server, MTU runtergesetzt auf 1400 (da viele AOL-Hörer, wär es ja ne möglichkeit gewesen), Portwechsel, alles half nichts.

Der Prozessor schläft (0,2% Systemauslastung), also auch daher keine Überlastung, Arbeitsspeicher ist auch nur zu 10% belegt.

Die Moderatoren als Ursache kann ich ausschliessen, da es a) mehrere Modis sind, und b) die selben Modis auf einem anderen Server (bei radiostream gehostet) keine Buffer-Schwierigkeiten haben.

Hat jemand vielleicht noch einen Anhaltspunkt, woran der Fehler noch liegen könnte?

Bin für jeden Rat/Tip dankbar. :)

Marco
 
#2
AW: Shoutcast-Server: Bufferproblem

Klingt nach mangelnder Bandbreite / schlechte Serveranbindung...

So ging es mir, als ich mal über einen USA-Server gestreamt habe... da sind die Anbindungen einfach nicht zuverlässig genug.

Christoph
 
#3
AW: Shoutcast-Server: Bufferproblem

Hallo :)

Serverstandort ist Deutschland, Anbindung ist wie oben auch schon genannt ein 100MBit-Port, der auch voll nutzbar ist. Hatte mal XAMPP direkt auf den Root-Server gesaugt (über 30MB innerhalb kürzester Zeit, den genauen Wert weiss ich nicht mehr, aber sauschnell ... hätte ich gerne mal daheim *fg*).

Danke sehr trotdzem :)

Marco
 
#4
AW: Shoutcast-Server: Bufferproblem

das problem ist, das ein gateway fehlerhaft sein kann beim provider, hatte ich auch bei 1st-housing. der zerstückelt den abgehenden traffic durch ausfälle im millisekundenbereich und dadurch ruckelt ein radiostream.

kann daran liegen, muss aber nicht ;)
 
Status
Nicht offen für weitere Antworten.
Oben