1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem mit Windows Media Encoder

Dieses Thema im Forum "Studio- und Sendertechnik" wurde erstellt von MargareteHub, 15. Oktober 2013.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MargareteHub

    MargareteHub Benutzer

    Hallo,

    für eine Testumgebung, habe ich mich mit dem Windows Media Encoder beschäftigt.

    Encoder läuft in er Pull Variante. Ports im Router sind frei, Firewall lässt den Encoder durch.
    IP Adresse und Port stimmen auch. Aber es kommt die Fehlermeldung bei abrufen des Streams:
    Windows Media Player kann die Datei nicht wiedergeben, da ein Problem mit dem Netzwerk besteht Proxyserver usw.

    Liegt es daran, dass ich eine feste IP6 Adresse habe und man nur Streams mit IP4 Adresse abrufen kann ?
    Das wirds wohl sein oder ?
     
  2. Nobier

    Nobier Gesperrter Benutzer

    Ich dachte das läuft schon alles ;)....
     
  3. dea

    dea Benutzer

    Hast du das? ô.Ô

    Könnte schon sein. Was dein lokaler Rechner an Konnektivität präferiert, kannst du entweder in der lokalen Policy ("DOS-Box: netsh int ipv6 sh pre) nachlesen oder einfach über einen Aufruf von http://ipv6-test.com/ prüfen. Allerdings sollte trotzdem auch IPv4 möglich sein, denn sonst könntest du so manche Webseite gar nicht aufrufen. Wenn die nur per IPv4 erreichbar sind, sollte ein PC diese auch dann öffnen können, wenn er eigentlich IPv6 bevorzugt, was aktuell die wenigsten tun. I.d.R. muss man sie über die Prefixpolicy dazu zwingen.
     
  4. MargareteHub

    MargareteHub Benutzer

    Hallo Dea,

    Danke ! Also er zeigt folgendes an:

    Was kann ich jetzt tun ?
     

    Anhänge:

  5. dea

    dea Benutzer

    Nunja. Nach IPv6 sieht das auf jeden Fall schon mal nicht aus. Insofern wirds auch kein Problem damit geben. Es sei denn, eine Komponente läuft auf einem Server, der ausschließlich mit IPv6 angebunden ist. Das halte ich aber gegenwärtig für nicht so wahrscheinlich.

    Was aus deiner Ausführung auch nicht hervor geht: ob du deine Experimente auf genau einem Rechner (localhost) machst, oder innerhalb deines privaten LAN, oder auf WAN-Rechnern. Welche Betriebssysteme kommen zum Einsatz? Ist dort IPv6 überhaupt aktiv? Macht der Internet-Router das überhaupt mit? Wenn ja, was bietet der Provider an (wahrscheinlich auch nur 6to4)?

    Fragen über Fragen.
     
  6. MargareteHub

    MargareteHub Benutzer

    Hallo Nordbier,

    im Sender läuft alles ! Ich bau' mir das zuhause mal nach, ist Teil meiner Facharbeit. Und den Techniker im Sender will ich auch nicht immer fragen, der hat von mir genug.:)

    Hallo Dea,

    ich habe einfach zwei Rechner zuhause. Beide mit Netgear Router, Windows 7 64 bit (beide) auf denen läuft der Windows Media Encoder. Beim anderen Rechner Windows Media Player. Im Netzwerk, kann ich den Stream abrufen mit dem Windows Media Player. Nur von außen geht es nicht.

    Im Router sind die Ports die man mit der Pull Variante beim Windows Media Encoder eingeben muss eingetragen und freigeschaltet, sie lassen das durch. Firewall lässt Encoder durch.
    Sicherheitseinstellungen sind Okay.

    Zum abgreifen nehme ich ja dann wenn ich im Encoder zum Beispiel Port 8080 eimgebe (und Router hat ja die gleiche Portnummer)
    meine Feste IP Adressse also zum Beispiel:

    mms://123.456.678:8080

    Wie gesagt auf dem gleichen Rechner, kann ich diesen Stream hören. Von außen (übers Internet geht es nicht da kommt die Fehlermeldung: Netzwerkproblem oder Proxy Server Problem)
    Ich bin mit meinem Latein am ende.
     
  7. Nobier

    Nobier Gesperrter Benutzer

    Kannst du mal einen Screenshot von deinen Port-forwarding Einstellungen im Router machen?
    Falls du nur für Port 8080 Regeln festgelegt hast, solltest du die gleichen Regeln auch für Port 8081 festlegen.
    In der firewall das gleiche Port 8080 und 8081. (immer der eigentliche port +1)
     
  8. Nobier

    Nobier Gesperrter Benutzer

    upppps doppelpost....
     
    Zuletzt bearbeitet: 15. Oktober 2013
  9. MargareteHub

    MargareteHub Benutzer

    Hallo Nordbier, Danke für Deine Hilfe - also hier die Bilder ! :thumpsup:
     

    Anhänge:

    • 1.jpg
      1.jpg
      Dateigröße:
      76,2 KB
      Aufrufe:
      9
    • 2.jpg
      2.jpg
      Dateigröße:
      188,3 KB
      Aufrufe:
      9
  10. Nobier

    Nobier Gesperrter Benutzer

    Kein Problem @MargareteBub!
    Was für einen Internetanschluss hast du? dsl oder cable??
    und welcher provider?

    und ich sehe da einen fehler beim port forwarding. die ip´s sollten eigentlich identisch sein!
     
    Zuletzt bearbeitet: 16. Oktober 2013
  11. MargareteHub

    MargareteHub Benutzer

    Ich habe DSL der Telekom 16.000. Habe die IP's identisch gemacht. Wenn ich auf ipconfig gehe, dann hat mein Rechne die Endung 02. Auch bei 8081 steht jetzt am ende 02 richtig so ?
     
  12. Nobier

    Nobier Gesperrter Benutzer

    16000er DSL ist aber nicht ausreichend um PCM zu streamen.
     
  13. dea

    dea Benutzer

    Wenn der Router - was ich so jetzt nicht weiß - lokales Loopback beherrscht, dann ist die Geschwindigkeit des DSL egal. Der Router "schwindelt" dem Clienten im LAN dann eine WAN-Verbindung vor und spricht den entsprechenden Server im LAN an, ohne das WAN-Interface hardwaremäßig zu benutzen. Schwieriger wird es, wenn man einen ausgelagerten Proxy zum Verbindungstest benötigt. Dann stellt der Client die Verbindung über diesen her, was dazu führt, dass der Proxy dann übers WAN den Server zu kontaktieren versucht, dieser die Daten über den Router und damit DSL erst dem Proxy im Internet zuliefert, wo der Client sie wieder abholt. Da greift dann auch das Upstreamlimit, was bei ADSL16 typischerweise 1 MBit/s beträgt. Für 16 Bit 44.1 kHz PCM ganz eindeutig zu wenig.

    Und @MargareteHub: eine
    hast du auch nicht. Selbst wenn dein Router daueronline ist, erhälst du alle 24 h zwangsweise eine neue vom Provider. Wann das passiert, erfährst du wahrscheinlich im Log der Kiste. Sollte der Router keine Möglichkeit anbieten, diesen 24-h-Zwangsdisconnect automatisch in einen anderen Zeitrahmen zu verschieben und dort zu halten, könnte es sein, dass du die Trennung ausgerechnet zufällig inmitten der Arbeit erlebst und damit im Dunkeln tappst.
     
    Zuletzt bearbeitet: 16. Oktober 2013
  14. MargareteHub

    MargareteHub Benutzer

    Hallo,

    ich will ja nicht in PCM streamen, das macht bei uns nur der Sender. Ich will lediglich mit 128 kbit mal Daten bei mir zuhause einfach über das Internet schieben um es so auszuprobieren und damit ich mich etwas weiterbilde auf diesem Gebiet.
    Dazu bin ich bei DynDNSs.net. Ich habe eine feste IP Adresse. Die man jetzt nicht unbedingt bräuchte um mal für 5 Minuten zu streamen, aber das erschien mir verlockend.
    Wie gesagt: Innerhalb des Netzwerkes klappt es prima, nur Zugriff aus dem Internet da funktioniert es einfach nicht. Ich habs mit fester IP Adresse probiert und dan ohne feste, also dynamische vom Telekom Provider, beides geht nicht. Wer noch ne Idee hat, immer her damit :thumpsup:;):)
     
    Zuletzt bearbeitet: 16. Oktober 2013
  15. dea

    dea Benutzer

    Gut.
    Das ist auch normalerweise kein Problem. Da ginge auch mehr.
    Kann es sein, dass du einen registrierten Domainnamen mit einer IP-Adresse verwechselst?!
    Nein, ich glaube nicht, dass du zu Hause eine feste IP-Adresse hast. Wozu solltest du diese Kosten auf dich nehmen? Und: Wenn du eine feste IP-Adresse hättest, würde DynDNS nur noch die Hälfte Sinn machen, denn deren Sinn bestand eben primär darin, Usern mit dynamischen IPs unkompliziert einen Domainnamen zu Verfügung zu stellen (auch wenn man freilich heute durchaus auch feste Adressen mit den Namen und Webhops verknüfen kann.).

    Ich kenne den Windows Media Server nicht - habe damit nie arbeiten müssen. Wie es aussieht, scheint er aber deutlich komplizierter zu werkeln, als es Shoutcast v1.9.8 oder Icecast tun. Wenn ich in der Wikipedia dazu nachlese, sehe ich, dass für MMS-Verbindungen eine einfache Portweiterleitung für TCP (HTTP) nicht reicht. Demnach gilt es herauszufinden, welche Ports und welche Protokolle der Server auf deinem Rechner noch mit deiner Konfiguration öffnet. Das erfährst du mit netstat -a -o -n über ein Kommandozeilenfenster, die PID des Serverprozesses vom Taskmanager.

    Sollte das alles nicht weiterhelfen, sei dir eine Andere Audioserver-Anwendung empfohlen, die sich auf Netzwerkseite deutlich unkomplizierter verhält.
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen