1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

Dieses Thema im Forum "Internetradio- und Heimstudio-Software" wurde erstellt von DeHamm, 17. April 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. DeHamm

    DeHamm Benutzer

    Hallo Community,

    ich bin am verzweifeln, kann mir wer dieses Teil erklären:

    http://www.oddsock.org/tools/streamTranscoder

    Ich möchte doch nur wissen was ich alles machen muss, damit das Teil funktioniert, die Readme ist sehr, sehr bescheiden, beim Forum komme ich nicht weiter...

    Gibt es evtl. alternativen einen Stream auf eine niedrigere bitrate zu samplen UND diesen dann an einen anderen Shoutcast-Server weiterzureichen?

    Ich werde doch nicht der einzige sein mit diesem Problem?

    Der Shoutcast-Server läuft auf einem Webserver (Suse 8.2). Die einzige, einfachere Methode wäre, zwei Server-Instanzen starten und der DJ muss halt an beide seine Daten schicken, finde ich aber persönlich nicht zu prickelnd...

    Vorschläge?

    Gruß MIKA
     
  2. c.rothe

    c.rothe Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Ich habe gerade mal drüber geschaut und finde die Erklärungen in der Config-Datei eigentlich ganz akzeptabel.

    Es müsste genauso funktionieren, wie Du es Dir vorstellst.

    Als SourceURL die URL des High-Quality-Shoutcast-Streams angeben, dann die gewünschten Encoding-Parameter für den Low-Quality-Stream und dessen Daten angeben (der dazu passende Shoutcast-Server muss schon existieren) und das sollte es gewesen sein.

    Habe das Teil zwar noch nicht getestet, aber wenn Du noch Fragen hast, frag ruhig, Linux ist meine Welt ;)

    Christoph
     
  3. DeHamm

    DeHamm Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Linux iss Deine Welt, halleluja, Dich schickt der Himmer *hrhr*

    also eigentlich hab ich weniger mit der Benutzung und Konfiguration das Problem, eher mit der Installation :(. Dazu muss ich gestehen, das ich noch recht neu in der Linuxwelt bin (seit 3 Monaten schlage ich mich durch diverse Foren, Man-Pages usw.) und mir so nach und nach das Wissen anlache.

    Aber zu meinem Problem (ich versuche es gerade nochmal):

    Ich hab mit die Sources geladen, entpackt und nu gehts los...

    also ./configure gestartet, hatte erst Ogg, Vorbis, libcurl und libmad vermisst, kein Thema, mit Hilfe von YaST installiert, wunderbar! Nur jetzt häng ich bei diesem Fehler:

    Code:
    checking for liblame... no
    *** Could not run liblame test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means liblame was incorrectly installed
    *** or that you have moved liblame since it was installed.
    configure: error: must have libmp3lame installed!
    
    Ich weiß nicht woher ich das Teil herbekomme (per YaST habe ich es nicht, per google hab ich nur einen Clon gefunden) und installieren soll.

    Ich denke mal, wenn ./configure ohne Fehler läuft, sollte ich den Rest eigentlich schaffen :)

    Aber vielen Dank für Deine Hilfe...

    Gruß MIKA
     
  4. c.rothe

    c.rothe Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Hi,

    versuch es doch damit: http://lame.sourceforge.net/download/download.html

    Musst Du zwar selbst kompilieren, aber nach einem ./configure; make; make install sollte sich auch das andere Programm kompilieren lassen.

    Ein guter Anlaufpunkt für die Suche nach Linuxsoftware ist

    www.freshmeat.net

    Gruss,

    Christoph
     
  5. DeHamm

    DeHamm Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    mh, ist auch einwandfrei durchgelaufen die lame-sources, aber der öde Stream-Transcoder will immernoch die libmp3lame - geschichte...

    // Edit, sehe gerade das er etwas anderes geschrieben hat:

    Code:
    checking for liblame... no
    *** Could not run liblame test program, checking why...
    *** The test program compiled, but did not run. This usually means
    *** that the run-time linker is not finding liblame or finding the wrong
    *** version of liblame. If it is not finding liblame, you'll need to set your
    *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
    *** to the installed location  Also, make sure you have run ldconfig if that
    *** is required on your system
    ***
    *** If you have an old version installed, it is best to remove it, although
    *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
    configure: error: must have libmp3lame installed!
    
    ...ist wohl hoffnungslos :(

    Gruß MIKA
     
  6. c.rothe

    c.rothe Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Nix da,

    das klappt jetzt. Die Hinweise sind doch ziemlich gut.

    Mach mal ein

    find /|grep lib|grep lame

    und guck, wo die Library liegt.

    Dann guckst Du in /etc/ld.so.conf, ob der Pfad eingetragen ist und zum Schluss sagst Du dann

    ldconfig

    um den Cache upzudaten.

    Am besten dann nochmal neu einloggen und das Kompilieren nochmal probieren.

    Und denk dran: Linux ist benutzerfreundlich... es sucht sich sein Benutzer nur gut aus ;)

    Gruss,

    Christoph
     
  7. DeHamm

    DeHamm Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    super, läuft durch!!! Mein Dank ist Dir ein lebenlang sicher....

    Gruß MIKA

    PS: In die Datei hatte ich das schon eingetragen, jedoch hab ich nicht gewußt das man mit ldconfig noch was machen muss...
     
  8. c.rothe

    c.rothe Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Na dann,

    herzlichen Glückwunsch!

    Gruss,

    Christoph
     
  9. Sleeper

    Sleeper Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Hi

    Aslo ich habe Ogg Lame und Vorbis mit yast installiert
    aber drodsdem habe ich immernoch diesen fehler hier beim Installieren

    Code:
     *** Could not run Ogg test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means Ogg was incorrectly installed
    *** or that you have moved Ogg since it was installed.
    configure: error: must have Ogg installed!(Perhaps you need --with-ogg-prefix=/usr/local) 
    Ich bitte um hilfe
     
  10. c.rothe

    c.rothe Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Hi,

    Du verwendest also SuSE ? Dann installier mal die zugehörigen -devel Pakete!

    Das sind die Quellcodeteile, Includes oder Libraries die andere Programme benötigen, um sich dagegen zu linken.

    Einfach im YaST über die Suchfunktion nach dem Paket suchen und dann müsste es auch jeweils das Paket mit "-devel" hintendran geben.

    Christoph
     
  11. Sleeper

    Sleeper Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    ok Danke es geht jetzt
    aber er bleibt bei der install wieder hängen:
    Code:
     *** Could not run liblame test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means liblame was incorrectly installed
    *** or that you have moved liblame since it was installed.
    
    obwohl ich lame auch installiert habe, und zwar glame

    was könnte das sein
    Ps: ja ich benutze suse
     
  12. Sleeper

    Sleeper Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    ok habe lame nochmal installiert und er sagt mir jetzt das
    Code:
    checking for liblame... no
    *** Could not run liblame test program, checking why...
    *** The test program compiled, but did not run. This usually means
    *** that the run-time linker is not finding liblame or finding the wrong
    *** version of liblame. If it is not finding liblame, you'll need to set your
    *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
    *** to the installed location  Also, make sure you have run ldconfig if that
    *** is required on your system
    ***
    *** If you have an old version installed, it is best to remove it, although
    *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
    configure: error: must have libmp3lame installed! 
    habe wie auch oben geschrieben

    find /|grep lib|grep lame

    ausgeführt, nur das dumme ist wie heißt die Library??
    wist ihr das??
     
  13. Sleeper

    Sleeper Benutzer

    AW: [Shoutcast 1.9.4] 1 Stream -> mehrere Bitraten?

    Ok es geht alles supper habe en bissel gesucht und habe dann nur ein / vergessend as war alles^^
    ok danke für eure hilfe

    Cu
     
  14. bergo

    bergo Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Hallo,

    ich habe folgendes (kleines) problem.

    *** Could not run Ogg test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means Ogg was incorrectly installed
    *** or that you have moved Ogg since it was installed.
    configure: error: must have Ogg installed!(Perhaps you need --with-ogg-prefix=/usr/local)

    Leider habe ich null Ahnung, was ich machen soll (keine ahnung von Linux)

    Kann mir da einer des ausführlich erklären?

    (Das is ein ROOT Server, daher kann NICHTS an der Linux version verändert werden)

    MfG

    Bergo
     
  15. Pegasus

    Pegasus Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Noch ausführlicher, als die Fehlermeldungen, geht nicht.
    Entweder hast du libogg nicht installiert oder beim Übersetzen den falschen Pfad angegeben.

    Da du nicht sagst, welche Distri du verwendest, ist leider keine genauere Auskunft möglich.
     
  16. nwd

    nwd Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Ich würde an deiner Stelle ganz schnell die Shoutcast Version updaten. Deine ist nämlich exploitbar.
     
  17. Pegasus

    Pegasus Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Kannst du mal näher erklären, wen du jetzt meinst? Das erste Posting ist fast 2 Jahre alt und danach gings nur noch um OGG und nicht den SHoutcast.
     
  18. bergo

    bergo Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Ja also das problem habe ich jetzt im griff bekommen, ich hatte einfach die libogg unter einem falschen benutzer installiert.

    dennoch gibt es jetzt ein weiteres problem.

    Fehlermeldung:

    wenn ich die StreamTranscoder.sh starten will

    ./streamTranscoder.sh: line 8: streamTranscoder: command not found


    und wenn ich die StreamTranscoder.bsp starten will

    : command not founddsp: line 4:
    : command not founddsp: line 6:
    ./streamTranscoder.dsp: line 7: -: command not found
    ./streamTranscoder.dsp: line 8: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 9: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 10: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 11: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 12: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 13: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 14: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 15: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 16: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 17: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 18: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 19: !MESSAGE: command not found
    ./streamTranscoder.dsp: line 20: syntax error near unexpected token `('
    ./streamTranscoder.dsp: line 20: `!MESSAGE "streamTranscoder - Win32 Release" (b'sed on "Win32 (x86) Console Application")


    Welche isn nu richtig und was muss ich machen, dass es endlich funzt?

    (KURZE INFO... Des is nicht Shoutcast 1.9.4. sondern die mitlerweile neue version)
     
  19. Pegasus

    Pegasus Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Leider kenn ich den Inhalt von streamTranscoder.sh nicht, was aber der fehler sein kann, Linux unterscheidet Gross- und Kleinschreibung. Vielleicht ist "streamTranscoder" da falsch geschrieben. Ich werd mir morgen mal das Programm ziehen und ausprobieren, dann kann ich evtl mehr sagen.

    Vorher aber die Frage, hast du streamTranscoder in einem Verzeichnis kopiert, das in deiner PATH-Variable steht? Kontrollier mal, ob das Binary vorhanden ist, und wo es liegt.
     
  20. bergo

    bergo Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Soweit ich sehen kann ist alles richtig in die verzeichnisse kopiert.
    Nur bin leider blutiger anfänger und habe null ahnung von dem ganzen.:wall:
     
  21. Pegasus

    Pegasus Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Ich hab grad die aktuelle Version runtergeladen, eine Config erzeugt und dann per Defaulteinstellung gestartet.
    Das klappt auch bis zu dem Punkt, bis er keinen Stremingserver findet :D (den installier ich auch nicht extra zum testen)
    Ich hab auch kein streamTranscoder.sh, keine Ahnung, woher du das hast bzw. was das Script machen soll.

    Kompilier dir mal den Streamtranscoder neu aus den aktuellen Sourcen, zumindest bei mir funktinieren die.

    BTW: Auch wenn ich mich jetzt wieder unbeliebt mache, mit "Null Ahnung" einen Dedicatet zu betreiben ist nicht nur leichtsinnig, sondern IMO eine vorasätzliche Gefärdung des Internets. Ich vergleiche das so, als wenn jemand einen 40-Tonner fährt, der vorher nur auf nem Fahrrad gefahren ist. Das aber nur meine persönliche Meinung ganz nebenbei eingeschoben :D
     
  22. bergo

    bergo Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Natürlich machst du dich jetzt nicht unbeliebt. Habe ja auch schon einiges an erfahrung und ahnung aber eben nur in bezug auf den Shoutcast.

    Welche datei hast du denn gestartet, damit das reibungslos funktioniert hat?
    Und überhaupt welche version hast du denn benutzt.

    MfG

    Bergo
     
  23. Pegasus

    Pegasus Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Shoutcastversion: 1.2.8 (aktuellster Tarball, unter Debian Etch kompiliert und ein Paket gebaut)

    streamTranscoder -C -c ~/test.cfg -> eine Konfiguration in meinem Home-Verzeichnis erzeugt.

    streamTranscoder -c ./test.cfg -> Transcoder gestartet mit den Defaulteinstellungen

    Input Stream URL : (http://localhost/)
    Output Stream Type : (MP3)
    Output Server Type : (Shoutcast)
    Output Bitrate : (128kbps/44100Hz/Stereo)
    Output status : (Disconnected)
    Main Status : (Connecting To Output Stream)
    Output status : (Connecting)
    Output status : (Unable to connect to socket)
    Main Status : (Failed Connecting To Output Stream)

    Das heisst ,es funktioniert bis dahin, wo er zum Streamserver verbinden will, der natürlich nicht existiert ;)
     
  24. Pegasus

    Pegasus Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    Für alle, die evtl. auch Probleme haben. Es lag daran, das die Kompilation nicht erfolgte. Das Problem ist behoben und der Transcoder läuft. Wenn noch jemand Probleme damit hat, einfach fragen ;)
     
  25. Source

    Source Benutzer

    AW: [Shoutcast 1.9.4] Ein Stream, mehrere Bitraten?

    ah super gut also hab dat jetzt auchmal versucht mit dem oddstock trans...
    ich benutze einen linux server suse 9.1

    das problem ist:
    Code:
    checking for curl-config... /usr/local/bin/curl-config
    checking for CURL-LIB version >= 0.5.0... no
    *** Could not run CURL test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means CURL was incorrectly installed
    *** or that you have moved CURL since it was installed. In the latter case, you
    *** may want to edit the curl-config script: /usr/local/bin/curl-config
    configure: error: must have libcurl installed!
    
    obwohl curllib bereits installiert ist.
     

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen