IceCast-Probleme seit einiger Zeit; Ursache unbekannt


M*I*B

Benutzer
Hallo in die Runde,

ich fahre seit Jahren einen IceCast auf einem Windows- Server. Lief eigentlich immer vollkommen schmerzfrei, bis vor etwa 2-6 Wochen (genau kann ich nicht nachvollziehen, seit wann nicht mehr)

Eingestellt sind 4 Relay- Streams meiner Favoriten und zwei DJ- Mounts, die bei Nichtbenutzung auf Stream 2 und 4 zurück fallen.

Neuerdings erhalte ich beim Versuch, mit einem beliebigen Client einen Stream zu hören folgende Meldung im Log des IceCast:


[2021-02-04 23:21:07] WARN slave/slave.c Failed to connect to http://stream.dancewave.online:8080
[2021-02-04 23:21:07] WARN slave/slave.c Failed to connect to http://fr4.1mix.co.uk:8060
[2021-02-04 23:21:07] WARN slave/slave.c Failed to connect to http://fr4.1mix.co.uk:8000
[2021-02-04 23:21:07] WARN slave/slave.c Failed to connect to http://stream.dancewave.online:8080


Ein üblicher Master, welcher relay'ed werden soll ist nach folgenden Schema configuriert:

<relay>
<server>http://fr4.1mix.co.uk</server>
<port>8060</port>
<mount>/128h</mount>
<local-mount>/stream1</local-mount>
<on-demand>1</on-demand>
<relay-shoutcast-metadata>1</relay-shoutcast-metadata>
</relay>


Der Client verbindet also zum Server und fordert das entsprechende Relais-Mount an (OnDemand=1). Dann aber scheitert die Verbindung zum jeweiligen Master. Die relay'ten Streams an sich funktionieren einwandfrei und lassen sich auch auf dem Server problemlos aufrufen (z.B. http://fr4.1mix.co.uk:8060/128h ).

Spaßeshalber habe ich mal RocketStreamingAudioServer installiert mit exakt den gleichen URL's der Masterserver. das funktioniert vollkommen schmerzfrei, egal ob mit oder ohne SSL. Aber mit IceCast funktioniert das neuerdings nicht mehr (gleiche Ports bei IceCast und RSAS , Firewall natürlich entsprechend konfiguriert).

Hat da vielleicht irgend jemand eine glorreiche Idee?
 
Oben