Probleme mit AAC-Encoder und Debian Etch


Status
Für weitere Antworten geschlossen.

PARALAX

Benutzer
Hallo Leute! Bin echt am Verzweifeln...

Derzeit kämpfen mein Webmaster und ich mit einem riesigen Problem:

Wir nutzen seit einiger Zeit schon "Cast Control", das wir mittlerweile auf das "Media Control Panel" geupdatet haben. Es handelt sich dabei um eine Art GUI für verschiedene Shoutcast- und mittlerweile auch Icecast1 und 2 Server, die jeweils auch noch mit sc_trans1 und sc_trans2 Playlisten versehen werden können, als auch mit dem Transcoder V3 von Oddcast.

http://www.cast-control.net/products/mediapanel/

Mein Webmaster versucht mittlerweile seit fast einer Woche erfolglos "FAAC" bzw. einen AAC Codec zu installieren...ohne Erfolg! Ich habe schon viel hier herum gelesen und wußte bereits von den Problemen bzw. das es nicht möhlich ist, AAC Plus auf einem Linux-Server zu benutzen. Ein zusätzlicher Windowsserver kommt für uns allerdings nicht in Frage.

Nun sind diese Beiträge allerdings schon einige Zeit her (Ende 2007). Hat sich da was getan in Sachen Linux und AAC+? Falls nicht, wäre ich happy, wenn wir wenigstens der AAC-Codec bei uns irgendwie zum Laufen bekommen, was ja angeblich mit diesem "FAAC" Installationspacket gehen sollte. Mir läßt das einfach keine Ruhe mehr.:(

Zudem habe in der Config des Streamtranscoder V3 folgende Einstellung in der Config entdeckt:

# Output codec selection (Valid selections : MP3, OggVorbis, Ogg FLAC, AAC, AAC Plus)
Encode=AAC

...aber bei bei der Einstellung "AAC Plus" die gleiche Fehlermeldung, wie bei AAC.

Leider habe ich selbst keinen Zugriff auf den Server, weiß aber wohl von den Fehlermeldungen, die wir bekommen. Das Verrückte daran ist, das eigentlich alle Dateien, die gebraucht werden, vorhanden sind, jedoch angeblich in's falsche Verzeichnis installiert bzw. kompiliert werden.

Hier mal ein Auszug aus der Logdatei des Transcoders:

11/02/09 23:31:01 Info(streamTranscoderv3.cpp:65): Encoder 1: Not compiled with AAC support
11/02/09 23:31:01 Error(liboddcast.cpp:2028): Not compiled with AAC support
11/02/09 23:31:01 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnecting
11/02/09 23:31:01 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnected
11/02/09 23:31:01 Info(streamTranscoderv3.cpp:65): Encoder 1: Encoder init failed
11/02/09 23:31:01 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnected from server

Mit AAC Plus:

11/04/09 18:37:32 Info(streamTranscoderv3.cpp:65): Encoder 1: Password OK
11/04/09 18:37:32 Info(streamTranscoderv3.cpp:65): Encoder 1: Not compiled with AAC Plus support
11/04/09 18:37:32 Error(liboddcast.cpp:2139): Not compiled with AAC Plus support
11/04/09 18:37:32 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnecting
11/04/09 18:37:32 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnected

Vom Betreiber des "Cast Controls" haben wir folgendes Feedback dazu erhalten:

If the compilation of Stream Transcoder V3 cannot find the libraries you could modify the ./configure or make files to point directly to this library than attempt compilation.

Unser Webmaster schrieb mir dazu:

Im transcodereverzeichnis wird diese erstellt jedoch nicht da hin kopiert wo sie gebraucht wird

im configure kann ich angeben per variable *wo meine libverzeichnise sind aber das nutzt nix wenn der die dateien nicht da hin installliert

Vielleicht kann Jemand damit was anfangen.

Da wir mittlerweile schon fast eine Woche versuchen, das Ding ans Laufen zu bekommen und natürlich keine 100$ für die "Full Installation" des Media-Panels bezahlen wollen für eine Sache, die wahrscheinlich in ein paar Minuten erledigt wäre (wenn man weiß wie es geht), bitte ich hier dringend um eure Hilfe!!!

Vielleicht ist es auch nur eine Konfigurationsgeschichte oder ein falscher Compiler wird verwendet...keine Ahnung.

Jedenfalls wären ich/wir bereit, die Hilfe entsprechend zu entlohnen, sofern sie günstiger wäre als umgerechnet 100 AUD (australische Dollar), je nach Arbeitsaufwand. Bitte meldet euch schnell, falls ihr euch mit sowas auskennt und uns auf jeden Fall mitteilen könnt, woran der Fehler liegt bzw. gelegen hat (das wäre das Wichtigste für uns für den Fall einer kompletten Neuinstallation).

Ich sichere hiermit eine Bezahlung bis zu 50€ auf jeden Fall zu, sollte die Sache etwas komplizierter werden.

Die genaue Serverversion findet ihr hier: https://confixx.empire-multimedia.de/phpsysinfo3/index.php?disp=dynamic

Bitte meldet euch hier im Forum oder bei mir per PN so schnell wie möglich.

Vielen Dank!!!
 

Inselkobi

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Jetzt hast du erstrecht verloren. :rolleyes:

Der Tipp war naemlich mehr als nur hilfreich.
Wie - du hast ihn nicht verstanden?
Dann feuer deinen 'Webmaster'/'Techniker' oder wie auch immer, denn der Fehler wird dir ganz offen angezeigt.
 

PARALAX

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Sorry, das Untere hab ich übersehen. Ich sehe die Fehlermeldung. Sie steht ja auch in den Logs des Transcoders. Das Problem an der Sache ist, das Er die Datei einfach nicht kompliliert und Keiner von uns weiß warum. Selbst Experten, die ich angesprochen habe wußten es nicht und ich dachte, das sich hier auch Experten herum treiben. Vielleicht habe ich mich geirrt oder es gibt einfach keine Möglichkeit, wie ich schon befüchtet hatte, AAC auf dieser Serverversion zu nutzen. Wenn dem so sein wollte, dann sagt es mir ruhig. Dann ziehe ich den Installationsservice gleich wieder zurück. Denn die 100$ kann ich mir dann sparen für andere Dinge.
 

PARALAX

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Scheinbar geht es doch nicht auf Debian Etch. Folgendes habe ich soeben per Mail vom Installationsservice bekommen. Also wenn selbst die Softwareentwickler das nicht schaffen, dann glaube ich nicht, das es noch bei Jemand Anderem läuft. Falls doch, lasse ich mich gern vom Gegenteil überzeugen.

What we have discovered is that the example configuration file that STv3 provides is invalid, it appears the configuration must be wrapped with double quotes to support "AAC Plus" rather than just listing AAC Plus in the config file as the file instructs to do. We have made the adjustments in our software however there still appears to be a problem with AAC & AAC Plus regardless.

>From the ./configure results it appears AAC and AACP are being detected but for some reason not functioning, it could be due to links in the software pointing to outdated libraries or such however we have made a step forward by discovering the issue above. The service will now connect and attempt to stream however no data is being transmitted, this could be due to either the aacp encoder or aacp decoder not being linked or functioning incorrectly. It should also be noted that the stream is listed as MPEG at this stage.

So as it appears there is a problem with Stream Transcoder V3 itself and there unfortunately is not much else i can suggest.
We are more than happy to refund the installation cost as we have come to no result.

If this feature is an absolute must for you than i would recommend Windows 2003 where AAC and AACP appear to function fine, we know another customer has apparently been using this as he had advised us to use an earlier .dll file for the aac support which seems to function better.
 

DaMoAK

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Warum fragst du, wenn du alles besser weißt?
AAC lief übrings auch schon auf unserem Debian System. ;)
 

PARALAX

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Dann mach doch mal einen Vorschlag, was man noch machen könnte außer eine Neuinstallation mit aktuellen Libraries drauf zu hauen, was zwangsweise bedeuten würde, das wir die ganze Webseite neu machen müßten. Selbst unsere Serverexperten wußten da keinen Rat.
 

McBong

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Dann mach doch mal einen Vorschlag, was man noch machen könnte außer eine Neuinstallation mit aktuellen Libraries drauf zu hauen, was zwangsweise bedeuten würde, das wir die ganze Webseite neu machen müßten. Selbst unsere Serverexperten wußten da keinen Rat.

Was hat denn eine Neuinstallation mit erneutem Erstellen deiner Homepage zu tun? Herzlich wenig, dank Backup!

Mfg. Mc_Bong
 

caraoge

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Habt ihr nach dem Compilieren von FAAC auch den streamTranscoder von Hand compiliert?
Wenn ihr fertige Binarys genommen habt, oder den streamTranscoder vor der FAAC Installation compiliert habt, geht kein AAC.
Laut den Fehlermeldungen die du gepostet hast sieht das nämlich genau so aus.

Wenn du AAC+ willst, schau dich mal nach HE-AAC+ und den MP4 Tools um.

Und Experten scheinen deine sogenannten "Serverexperten" nicht zu sein. Man muss keine Webseite neu machen, nur weil der Server neuinstalliert wird.
Einfach kurz ein Backup ziehen, dass man später wieder zurückspielt. Je nachdem wie schnell ein Server neuinstalliert ist, dauert der Gesamte Prozess nicht mal eine Stunde.
 

PARALAX

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Nun, vielleicht habe ich es etwas zu undeutlich ausgedrückt. Natürlich bleiben die Daten der Seite, Datenbakne, etc. erhalten. Aber für die Konfiguration und Einrichtung aller Rechte und das ganze Zeug, was nicht gesichert werden kann, braucht schon ein paar Tage. Schließlich nutzen ja noch andere Kunden den Server.

Der Transcoder wurde soweit ich weiß wohl nicht von Hand compiliert, damit kenne ich mich auch nicht aus. Ich kann nur das weiter geben, was und der Service gesagt hat und der kennt sich nicht mit Programmierung aus sondern kümmert sich nur um die Installation der Software. Aber da es ja nicht daran gelegen hat, müssen wir wohl erstmal drauf verzichten. Ich geb es aber nochmal so weiter, vielleicht findet sich ja doch noch ein Weg oder es möchte uns Jemand von euch helfen. Gibt es ein paar Beispiele, wie man es machen könnte?
Vielen Dank erstmal...
 

SwenJahn

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Ich möchte gerne zu diesem Problem mehr Informationen geben.

Folgende dinge funktionieren:

MP3, OggVorbis, Ogg FLAC

ES geht nicht:

AAC und AAC Plus

Beim Kompilieren von streamstranscoder3 bekomme ich bei ./configure folgende ausgabe.


--------------------------------------------------------------------------

Using username "root".
Last login: Wed Nov 4 22:21:54 2009 from p5b2cab83.dip0.t-ipconnect.de
Linux empire-multimedia.de 2.6.18-6-amd64 #1 SMP Sun Feb 10 17:50:19 UTC 2008 x8 6_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
empire-multimedia:~# tar xzf streamtranscoderv3-3.1.11.tar.gz
empire-multimedia:~# cd streamtranscoderv3-3.1.11
empire-multimedia:~/streamtranscoderv3-3.1.11# make
Making all in liboddcast
make[1]: Entering directory `/root/streamtranscoderv3-3.1.11/liboddcast'
make[1]: Für das Ziel »all« ist nichts zu tun.
make[1]: Leaving directory `/root/streamtranscoderv3-3.1.11/liboddcast'
make[1]: Entering directory `/root/streamtranscoderv3-3.1.11'
make[1]: Für das Ziel »all-am« ist nichts zu tun.
make[1]: Leaving directory `/root/streamtranscoderv3-3.1.11'
empire-multimedia:~/streamtranscoderv3-3.1.11# clear ? ./configure
empire-multimedia:~/streamtranscoderv3-3.1.11# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld -m elf_x86_64
checking if the linker (/usr/bin/ld -m elf_x86_64) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking for ANSI C header files... (cached) yes
checking for an ANSI C-conforming const... yes
checking for libogg... ok
checking for libvorbis... ok
checking for struct ovectl_ratemanage_arg... yes
checking for libmad (>= 0.12.0)... yes
checking for libFLAC... yes
checking for liblame... yes
checking for faacEncOpen in -lfaac... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating liboddcast/Makefile
config.status: executing depfiles commands
empire-multimedia:~/streamtranscoderv3-3.1.11#

-------------------------------------------------------------------------

Laut ausgabe wir faacEncOPEN gefunden.

Wenn ich jetzt make und make install ausführe und den Transcoder starte steht in der Logdatein von Transcoder3 folgende meldung.


11/09/09 22:59:26 Info(streamTranscoderv3.cpp:131): Encoder 1: AAC: Quality 100/44100Hz/Stereo
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnected
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Connecting
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Socket connected
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Password OK
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Not compiled with AAC support
11/09/09 22:59:26 Error(liboddcast.cpp:2028): Not compiled with AAC support
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnecting
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnected
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Encoder init failed
11/09/09 22:59:26 Info(streamTranscoderv3.cpp:65): Encoder 1: Disconnected from server

Das kompilieren hat so scheinbar geklappt. Transcoder ist ausführbar und andere Streamformate funktionieren ohne probleme nur AAC woll nicht so recht.

Ich wäre Euch sehr dankbar wenn mir jemand helfen könnte.

Mein System ist Debian 4 64 bit
 

PARALAX

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Was ich noch hinzu fügen möchte, das zwar das Senden an sich klappt, das Format jedoch als MPEG ausgegeben wird und nicht als "aac" bzw. "aacp", so wie es sein sollte. Keines der beiden Formate wird gestreamt. Livestreaming hingegen war nie ein Problem, selbst mit Videodaten. Nur über den Transcoder geht es nicht.
 

caraoge

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Welche Packete für AAC bzw. AAC+ habt ihr denn Installiert?
Und kam beim erstellen der Packete irgendeine Fehlermeldung?
 

SwenJahn

Benutzer
AW: Probleme mit AAC-Encoder und Debian Etch

Es wurde FAAC 1.28 von der Webseite http://linux.softpedia.com/progDownload/FAAC-Download-554.html installliert

Die weiteren Packete die fehlen beim Komilieren von Transcoder wie

liblame
liblame-dev

faac_1.25-0.1_amd64.deb
libfaac0_1.25-0.1_amd64.deb
libfaac-dev_1.25-0.1_amd64.deb
libmp4v2-0_1.5.0.1-0.3_amd64.deb

Fehlt den noch irgend was ?

Fehler konnten bei dir installation nicht festgestellt werden.

Eventuell fehlen ja noch irgend welche Packete oder Decoder/Encoder
 
Status
Für weitere Antworten geschlossen.
Oben